Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-30-2003, 02:58 AM
Registered User
 
Join Date: Apr 2003
Posts: 28
Fuel Guage jumpy after filling gas while engine on

Hey guys. This is like the 5th small problem I've encountered with my 99clk320, and I've only had it for a month! It's ridiculous.

Anyway, I know there are lots of posts in this forum about this issue, most suggest that the problem is probably a faulty fuel sender or some dirty contacts.

I just want to say that this problem only started for me yesterday when I pulled up to an Exxon full service gas station. The guy started gassing up when I realized that the engine was still running. Well, I went ahead and shut off the car.

Once the refilling is done, I drive away and notice that the fuel guage is at empty! Since then, its been jumpy. Goes to empty, then back up to 90 percent, then the light comes on intermittently, then stays on, then goes to full, etc.. etc...

Did I screw up something electronically by shutting off the car during the refueling process, or is this a purely mechanical thing?

Thanks all, this forum is FANTASTIC!
Reply With Quote
  #2  
Old 05-01-2003, 03:48 PM
Registered User
 
Join Date: Apr 2003
Posts: 320
Filling the gas with the engine running has no adverse effect on the fuel gage. North (Midwest) it is done all the time in the winter. It is does not pose any safety hazard either.
__________________
Zafar
94 E320 58000 Miles
Reply With Quote
  #3  
Old 05-01-2003, 08:59 PM
Registered User
 
Join Date: Apr 2003
Posts: 28
thanks for your reply zafarhayatkhan.
i guess i meant to ask if it would short anything out if:

i started to gas with the car on
WHILE the gas is pumping, i went and shut off the engine.

only after this did i start seeing problems. i thought maybe i shorted something.

thanks or any input.
Reply With Quote
  #4  
Old 05-02-2003, 09:06 PM
Registered User
 
Join Date: Apr 2003
Posts: 320
99clk320, I am curious as to what other problems have you had?

One other thing you can do is, find out the related fuses from the owners manual. I am not sure what type of fuses are installed in the 99, but if they are anything like the 94, I would replace the fuse and see what happens. Spare fuses are probable provided in the fuse box.
__________________
Zafar
94 E320 58000 Miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page