Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-17-2000, 09:30 AM
Registered User
Join Date: Feb 2000
Location: Hicksville, NY
Posts: 63
Greetings! I'm new here and judging from the posting I have been reading everyone seems quite helpfull. Glad I found this place!!!

Here is my question. I just got a 90 300CE-24 w/ 135,000 miles on it. Basically everything is original on it, never been wrecked or painted. It runs and looks like its brand new.

When cruising on the highway at 60 MPH, I am getting about 3000 RPM's. Is this normal or is it a bit high?

I have driven quite a few MB in the past and know that they all start off in 2nd gear unless you hit the kick down switch behind the gas pedal. I notice that my car will go to 1st when starting off when the accelerator is pressed 3/4 of the way down without even touching the kick down switch. Is this normal? Or is my vac control module getting hung up or needs adjusting.

I just had the car serviced and there wasn't anything unusual with the tranny fluid and there wasn't any metal shaving in the pan. The car hits all the shifts at the proper times, though they are very firm shifts.

Thanks in advance!

Reply With Quote
Old 02-17-2000, 10:59 AM
Nick Jamal
Posts: n/a
Congratulations on your new ride - I've always liked the CEs...
Can't say anything definite re the rpm at highway speed, although it sounds right to me. My 300E and TE will also downshift into 1st at ~3/4 throttle, so I'm guessing that this is normal, too.
Reply With Quote
Old 02-17-2000, 01:45 PM
Posts: n/a

You might want to compare notes and contact Jim Fisk at He also has a 1990 300CE-24. You can see his ride at

Hope this helps.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 10:53 AM
Help! Engine Dead???? Breckman99 Diesel Discussion 17 05-09-2005 11:26 PM
1990 300E Engine Rebuild? masonte Tech Help 3 10-09-2004 01:56 PM
FS: NEW Engine Cover for 300E, 300CE, 300TE Benzwood Mercedes Used Parts For Sale & Wanted 8 09-04-2003 06:31 PM
Getting V8 engine swapped 300ce smogged davidteri Tech Help 0 07-09-2001 09:12 PM

All times are GMT -4. The time now is 04:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page