Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-01-2003, 03:23 PM
Registered User
Join Date: Apr 2000
Posts: 16
190E won't start

Bought a 1986 non running 190E 2.3 (because I have a '91 since new, now has 238K on it - no problems , and just recently sold a 86' 190 that we used as a beater) and found that the fuel pump was dead. Replaced it with a used one and put a new filter on. Have plenty of pressure ( not measured though) at the Fuel distributor, but when I crack open any of the lines at the top - no fuel. Any ideas. Can I measure the voltage at the connectors so make sure I am getting a signal from the computer? Thanks
Reply With Quote
Old 05-01-2003, 03:45 PM
Registered User
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
You don't need the computer for the car to run. Primary fuel pressure and injection supply is mechanical. Filter screens may be plugged, or the fuel distributor bad.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page