Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-17-2003, 10:14 PM
Posts: n/a
stalling when idling or braking...

hopefully someone out there can help me with this. my 190E has started to stall frequently when i am slowly braking towards a light or a stop sign. it immediately turns over again. it has a hrad acceleration on occasion. if i'm in stop and start traffic, the idle speeds up and slows very erratically; sometimes when it's idling in park, it justs stops running. otherwise the car runs great. the other thing is: this stuff only happens in warm weather...
Reply With Quote
Old 05-18-2003, 03:56 PM
Registered User
Join Date: Mar 2003
Location: New York
Posts: 101
Try a new idle position sensor

Check your Idle position sensor see if it switch
Reply With Quote
Old 05-18-2003, 06:12 PM
Registered User
Join Date: Mar 2003
Posts: 64

First thing to do is search the archives. There is a mountain of information on stalling problems. You'll need a good automotive multimeter to test the various fuel injection sensors and the MB CD to get the correct values for the sensors - a lot of it is in the archives.

Your problem sounds exactly the same as mine. Mine was solved by replacing the Air Flow Meter unit - specifically the potentiometer - it tends to wear out. I also found that the zero position of the throttle plate on the air flow meter was incorrectly set and this can lead to idle surging up and down.

Unfortunately there are a lot of things that can cause idle problems so you'll have to work through them systematically. I would suggest starting with the mechanical issues first such as looking for vacumn leaks etc.

Read through as much info as you can find on this site it's likely your problem has been encountered before.

Reply With Quote
Old 05-18-2003, 07:32 PM
Registered User
Join Date: Nov 2002
Location: Temecula California
Posts: 47
Check all vaccum lines and hoses, and mas air flow senor
Reply With Quote
Old 05-18-2003, 10:45 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
You didn't say what year your car is -- early models have, I think, KE Jetronic, later ones LH Jetronic injection, and the problems will be different.

If you have KE Jetronic (with a fuel distributor and no air flow sensor) check the idle control valve and associated hoses -- with age, the hoses leak, so dirt gets into the idle control vavle, making it stick closed as you lift off the gas, then fail to open at all as you stop, so it stalls. Loose hoses will cause erratic idle and mixture control problems, so you get surges and stalls from that, too.

The OVP relay can also start dropping voltage to the control circuit, causing the mixture to wander and the ignition to cut in and out.

LH Jetronic will give you fits if the hose between the air flow senor and the throttle valve is leaking, as it won't "see" the idle air and will shut the fuel off, causing an overlean condition, and the O2 sensor circuit can cause surges as the mixture goes out.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Old 05-18-2003, 11:32 PM
Posts: n/a
follow up...

sorry for the sketchy info on my first car is a 1988 2.3. last summer it was a bit of a problem, it stalled every few weeks. as soon as the weather got cool it stopped. now that the warm weather is here again, it's back with a vengeance. stalling 10-12 times during the day. when the sun goes down it is much less of a problem. the problem seems to increase the longer i am on the road...

before it started stalling all the time, I noticed that the engine was racing very erratically. rising and falling in a very abrupt manner. it still does this when it is in stall mode...when i am at a red light it idles very erratically, shuddering, seems about to die, then speeds up again and then down again and then finally stalls. if i race the engine it seems to stay way up there, and then very gradually comes down again, only to start its erratic breathing all over again....

anyway, thanks so much for the advice and insight so far! I really appreciate the responses to my query. I've read all the post in this forum relating to stalling issues with the 190E, and think i've got certainly got a much better handle on what it might be.

i love the car and I really want to solve this problem. it's really spoiling our relationship!

will report back asap!
Reply With Quote
Old 10-21-2003, 06:28 PM
Registered User
Join Date: Feb 2003
Location: Richmond, BC
Posts: 374
Did you open up the air filter cover and much engine oil on the air filer housing???? If yes, probably engine problem

Did you clean up the idle control valve??
Reply With Quote
Old 10-28-2003, 01:27 AM
Registered User
Join Date: Feb 2003
Location: Richmond, BC
Posts: 374
My problem seem fixed today.

Today, I picked up my 87 MB 190E from Garage. My stall problem seems no anymore after changed valve stem seal, idle control valve, fuel pressure regulator and OVP.

Before I have stall when braking (after engine warm) and can start again immediately. Seem rpm drop too low. Now, everything is OK. Hope this will help.

Last edited by jeff-abalone; 10-29-2003 at 07:21 PM.
Reply With Quote
Old 10-28-2003, 04:22 AM
Registered User
Join Date: Sep 2003
Location: France
Posts: 487
[QUOTE]Originally posted by UKEvo

I also found that the zero position of the throttle plate on the air flow meter was incorrectly set and this can lead to idle surging up and down.

Hello UKEvo,
have you been able to adjust the zero position of the throttle plate, I have to do it on my 260E, 1988?
If yes, is it easy to do it?
Could you explain the step by step procedure you used?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page