Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-22-2003, 07:18 PM
Registered User
Join Date: Nov 2000
Location: Vernon, CT
Posts: 1,845
W124 climate control slow to respond

The climate control in my '87 TD is acting real funny. After pushing a button, the system takes 15 seconds or more to catch up. Yesterday I selected "ec" and nothing at all was happening. I had the fan speed on Auto but no air was coming out, so I switched to High and nothing. I hit the defrofter button and it took about 15 seconds for it to respond. Then I hit the ec button again, and the defroster didn't stop. I hit the off button and it took 10 seconds or so to actually stop. Also at times the system will blow hot air when I have a cool temp. selected. I pushed the A/C button and the A/C compressor did not come on. I am highly suspecting the climate control panel is messed up. Any ideas on this would be appreciated. Also, all this is happening with the car warmed up.
1994 MB E320 Coupe (199,500 mi)
1992 MB 190E 2.6 (173,000 mi)
1983 Porsche 911SC (148,000 mi)
2004 Volvo V70 2.5T (198,000 mi)
PCA member
MBCA member
President of CT/Westchester Section
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page