Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-01-2003, 02:33 PM
John Freeman
Posts: n/a
1990,350 SDL with sticky upshift problem

Hi I've got a 1990 350SDL with @198,000 miles on her, she runs great EXCEPT if on highway runs of over an hour recently she has begun to labor to get into 4th gear and will after continued driving will also develop problems going up into 3rd. After the vehicle is stopped and shut down for 20 to 30 minutes it will be fine running upto highway speeds again for about and hour...We have been pulling our hair out and had NO luck tracking down this gremlin!! Anyone out there have a similar problem?? She runs too well for it not to be an overlooked item!! Thanks!
Reply With Quote
Old 06-01-2003, 02:51 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Try replacing the filter.

As the reverse clutches go they can fill a filter in just a few miles. You problem is classic symptom of a packed filter.

If that don't work I would loosen and retorque the valve body. Internal leakage can cause such temp dependant problems.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page