Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-10-2000, 02:13 PM
Posts: n/a
It seems like the bulbs inside the clock and LCD display(climate control unit) are dead. Is it normal after driving my car for three years? Are there any other problems related to this? Can I fix this prolblem easily? I am gonna take my car to benz dealer sooon.. I don't want to hear dealer telling me it will cost me a fortune for a simple bulb change. Thanks.
Reply With Quote
Old 03-10-2000, 05:39 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
This gets worse and worse. Please get rid of this car before you have a really serious problem. With all of the electrical problems you describe, you might have a charging system that goes out of regulation and bangs the electrical system with excessively high voltage. Have it checked ASAP.

Jeff L
1987 300e
1989 300e
1987 BMW 325
Reply With Quote
Old 03-10-2000, 07:39 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
There are replacable bulbs behind the LCD instruments. Takes about 45-50 min to do. If the car is still under warranty so are the bulbs.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page