Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-03-2003, 02:25 PM
MBDad777's Avatar
Registered User
 
Join Date: Dec 2002
Location: Olympia, WA
Posts: 75
BAS/ASR Light & Cruise Control Help Needed

Quote:
Originally posted by Tony1628
My check engine light came on, so I disconnected the battery cable. Now the check engine light is off, but the ABS and BAS/ASR
come on.
Very similar problem in my '99 C280, but all the previous posts seem to be for earlier model cars. The BAS/ASR light comes on at random occasions and when it does, the cruise control doesn't work either. Nor does the ASR defeat switch. In checking the brake switch, one of the contacts inside it looked like it had been arching so I sanded them both smooth and put electrical grease on them. The light went off for a day and now it's back on.

Another post suggested brake dust buildup around the wheel sensors might cause a problem (???). I checked all my 10 amp fuses (per the suggestion of another post) and found nothing unusual. There didn't seem to be any fuses labeled "ASR," "BAS," "Cruise" or anything like that under the hood or in the trunk. Any input is greatly appreciated!
__________________
2003 Hyundai Santa Fe, Silver
1999 C280 Sport, Black
1997 Ford Escort, Toreador Red
Reply With Quote
  #2  
Old 06-03-2003, 06:22 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
You should scan the controller and see what it thinks is wrong. Proceed with testing from there.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 06-05-2003, 02:30 AM
MBDad777's Avatar
Registered User
 
Join Date: Dec 2002
Location: Olympia, WA
Posts: 75
I had the codes scanned and the only one that came up was for the O2 sensor, but that was because the car ran out of gas the other day and sent some water or something through the fuel system near the end.

When I start the car, the BAS/ASR light is off until the moment I press the brake pedal for the first time. Then it remains on until I shut off the car.

I also inspected and cleaned the magnetic rear-wheel rotation speed sensors. They were covered with metallic particles from who-knows-where. Unfortunately, the light is still on. I have a feeling it may still be the brake pedal switch. Anybody know how much one of those runs?

Any more ideas? Thanks, Dan
__________________
2003 Hyundai Santa Fe, Silver
1999 C280 Sport, Black
1997 Ford Escort, Toreador Red

Last edited by MBDad777; 06-05-2003 at 02:47 AM.
Reply With Quote
  #4  
Old 06-05-2003, 08:49 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
You are looking in the wrong controller if you got an O2 sensor code. You must look in the traction control. It could easily be a brake light switch problem.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #5  
Old 06-05-2003, 09:29 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Try replacing the brake lamp switch 001-545-01-09 for $15.50 OR spend the $$ & have codes read from TRACTION system.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #6  
Old 06-09-2003, 02:04 PM
MBDad777's Avatar
Registered User
 
Join Date: Dec 2002
Location: Olympia, WA
Posts: 75
Replaced the brake pedal switch. Problem solved.

I tested the old and new ones on my multi-meter but couldn't tell a difference. Oh well....

Steve and MB Doc: thanks for your input and expert advice!!!

Dan
__________________
2003 Hyundai Santa Fe, Silver
1999 C280 Sport, Black
1997 Ford Escort, Toreador Red
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page