Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-19-2003, 10:33 AM
Registered User
Join Date: Jul 2002
Location: Irvine, CA
Posts: 33

Have just completed installing new brake pads front and rear. Started to bleed system and renew fluid with a pressure bleeder. A test at 10# to the MC showed no leaks. Filled bleeder with two liters of brake fluid, contacted to master cylinder and applied 20# pressure. Immediately
one of the relief relays started spouting fluid.
Now I have no pedal. I have tried bleeding the system manually, got some air, then clear fluid,
still no pedal. Ifs it's the MC should the reservoir be replace also to correct the spurting?
Reply With Quote
Old 06-21-2003, 10:46 AM
Registered User
Join Date: Jul 2002
Location: Irvine, CA
Posts: 33
I have solved the problem with a new master cylinder and reservoir.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page