Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-05-2003, 01:15 AM
Registered User
 
Join Date: Jul 2003
Posts: 7
1990 300e over heated now no internal blower fan comeing on.

We had an issue last week we were driveing home and the Water Pump bypass hose blew out. (What a pain to replace that on a Sunday)

Since we were stuck in holiday traffic I switched the cars heater on as I was pulling over to try and take some heat off the motor (Was desperate)

When I did turn the heater on I heard the gurgling sound of liquid behind the dash, the fan kick in at high speed then stop.

Now the blower motor fan does not want to come back on.

When at speed you can feal cool air passing through the vents, but no fan. I checked the normal fuses that I could find under the dash but all seam fine.

ALso one of the 2 fans in front of the rad no longer kicks in. The smaller fan just stays off, someone said its blown and replace it, but again Im curious if there is a realy or a fuse. I put a meter across the fan power leads and see no normal short you would see in a blowin fan motor, as well the fan spins freely.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page