Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2000, 01:18 PM
rojogo
Guest
 
Posts: n/a
My 91'190 2.3 is running a little warm. The aux. fan does not kick on until the temp is at 120 c which is right at the red notch. The weather has not even gotten warm yet and I dont want to overheat. Is there any way to get the fan to come on sooner like it used too. Help!
Reply With Quote
  #2  
Old 04-03-2000, 02:09 PM
makakio
Guest
 
Posts: n/a
Search this topic - it's been covered oh - maybe 300 times already...
Reply With Quote
  #3  
Old 04-03-2000, 10:04 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Install a new thermostat!! Then make sure it has the main fan working, it should come on at about 105.

------------------
Benzmac:
Donnie Drummonds
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #4  
Old 04-05-2000, 12:37 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
Benzmac or anybody, if the fan comes on at 105 is this a bad thing...should the engine always heat up to 105 on a reasonably warm day, or should it only do this under stress like hot weather or sitting in traffic?

ROJOGO: If the fan still does not come on earlier after you change your thermostat them change your fan switch located behind the oil cap on top of the engine.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1977 450sl blinking brake light and running hot abe g SL Forum 1 11-13-2004 08:17 PM
300E running hot...HELP!!! mike690003 Tech Help 7 09-18-2003 02:29 AM
Running Hot robaincltnc Tech Help 9 04-27-2003 11:16 AM
Grandad's 124 running really hot; solved! azhari Tech Help 0 02-01-2003 05:10 AM
1987 300TD running hot HGV Tech Help 5 03-19-2002 08:49 AM



All times are GMT -4. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page