Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-16-2003, 09:39 PM
Registered User
Join Date: Jul 2003
Posts: 60
When Locking Lights dont Blink 3 times 98 E320

I hope all is well.
My manual reads, When Un-locking the car it should blink 1 time.
And, when Locking the car is should blink 3 times.

My car lights blink 1 time at Unlocking, However, no lights at Locking the car.

Any Idea?
Maybe this is the reason, my windows do not Open and close via the remote, after holding it for few seconds.


1998 E320
Reply With Quote
Old 07-16-2003, 09:58 PM
Southern's Avatar
Registered User
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Try your other remote, if it works with your other remote then try replacing the batteries in the remote that don't work.

The lights should blink three time when locking the car.
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
Old 07-16-2003, 10:10 PM
Registered User
Join Date: Jul 2003
Posts: 60
just replaced

I replaced the battries, I only have 1 key.

Reply With Quote
Old 07-17-2003, 05:36 PM
DR.DIESEL's Avatar
Senior Member
Join Date: Mar 2003
Location: Puget Sound, Washington St.
Posts: 522
That usually means there is a "zone" open or something is telling the alarm control module the car has a open switch.
I would closely look at all 4 door pin switches located under the latch striker. make sure they all work and operate the dome lamps
as well.
Check the trunk pin switch for correct operation of lamp.
Check your hood latch on the drivers side for microswitch damage
or operation.
Any of these being open will keep the alarm from arming and you won't get the 3 flash confrimation.
The central locking will operate however in theroy.
Good luck.
Reply With Quote
Old 07-17-2003, 09:44 PM
Registered User
Join Date: Jul 2003
Posts: 60

You are right, I checked the rear left door, apparently the plastic molding is missing and there is very little contact between the switch and the door. When I pressed the pin in, light worked and armed the doors.


I got a question, I opened the door and pushed in the pin, while locking the door with remote. I let go of the pin, but car alarm didnt go off? Should it make horn noise?

What do you think.. is there a time delay?
Or, since the door pin was never pushed, the previous owner, disengaged the horn sound?

Also, while I had the pin pushed with hand, I pressed the remote and held the unlock button, however, window and sunroof didnt open with remote.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:46 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page