Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-14-2000, 12:35 PM
Registered User
 
Join Date: Mar 2000
Location: Dallas, Texas
Posts: 218
Just replaced the thermostat and repaired monovalve. Car was running much cooler at first, now is starting to heat more than before. 60 degrees outside, and car is running at 100, then at 110 when I parked. Felt of the radiator, hot at the top and cold at the bottom. Radiator stopped up? Air in the system? I used MB coolant and WaterWetter. I have read about a citric flush available from dealerships. Would that help, or is a new radiator necessary?
Before the thermo replacement, was running at 90-95 on highway, 100 in town. There was only one way to put in the thermo with the notch. I have read through at least 20 posts, but unable to narrow it down.
Thanks for any ideas...
Robert



------------------
R Talley
84 300D-T
Reply With Quote
  #2  
Old 04-14-2000, 10:24 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If the radiator has cold spots, nothing besides its replacement will rectify the problem.

------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
We often overlook Fuel Pump damage--Low Sulfur Fuels and bad fuel (85 300D) Carrameow Diesel Discussion 16 11-15-2007 06:43 AM
Opinions on purchasing a 1987 300D swogee Diesel Discussion 12 05-03-2005 11:27 AM
1976 W115 300D motor into 1979 W123 300D sebtowne114 Diesel Discussion 5 04-14-2005 08:26 AM
auto tranmission problem in 1981 300d o2pilot Diesel Discussion 2 06-15-2004 12:19 PM
300D turbo slushbox vs 300D n/a 4 speed The Warden Diesel Discussion 5 05-28-2004 01:40 AM



All times are GMT -4. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page