Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-30-2003, 01:57 PM
Registered User
Join Date: Jun 2001
Location: Denver, Colorado
Posts: 127
300E '86 probable ignition coil issue

i have a 300E 1986 with close to 300,000miles on it. everytime i put the keys into the ignition and turn it to where the radio is on and the engine check light is on, i hear this god awful clicking sound coming from the engine. it keeps clicking even after i start the car and runing idle. today i took the air filter off just to see where to clicking was coming from and it was underneath the fuel distributor but close to the engine wall. the only thing that i can see thats near the engine wall and underneath the fuel distributor is the ignition coil. Do you guys think its the ignition coil? or is it something else thats causing this clicking noise near this particular area. while the keys where in the ignition and the clicking sound was going on, i pull almost every sensor thats accessable and pluged them back in to see if they were the cause to the problem...but that didnt work..

your thoughts and comments are appreciated..
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page