Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-07-2003, 08:58 AM
Registered User
Join Date: Aug 2003
Posts: 1
Cruse Control Problems 300E

I have been experiencing problems on my 1989 300E with the cruse locks out after a few minutes and then its difficult to engage again. The car may only travel 1.5 KM and then cruse switches off. I have visually checked the control unit below the inlet manifold...everything appears in order...any easy suggestions..Thanks
Reply With Quote
Old 08-07-2003, 01:03 PM
dtf dtf is offline
Registered User
Join Date: Jul 2003
Location: South East CT
Posts: 799
A quick try is make sure your tires are all good and the same size. The wheel speed sensors on my car picked up the difference between tires sizes and shut off the CC. Also do a search on throttle actuator - the two are related.
1994 E320 Wagon (Died @ 308,669 miles)
1995 E300 Diesel (194,000)
1999 E300 Turbodiesel (244,000 miles, dies at 255,000)
2006 Toyota Tundra SR5 AC 4X4 (115,000 miles)
2011 Audi A4 Avant (129,000 miles) hate this car!
BMW 330 xi 6 speed manual (100,034 miles)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page