Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2003, 11:35 AM
Registered User
 
Join Date: Nov 2001
Location: Port Harcourt, Nigeria
Posts: 28
Question Hot Engine wont idle

Hey Guys,
Here's the story, we went down town shoping, stop and go traffic, the whole round trip takes 2 1/2 hours, the car is turned off maybe 10 minutes at each store. On the way home the car when stopped in traffic, the engine idle's rough then stalls, If we 2 foot the car to keep with the traffic, holding the idle with my right foot, using neutral, after 10 minutes or so, the engine sometimes resumes it smoothness and we are back to a normal running car, and sometimes it needs to be 2 footed all the way.

The Facts:

We are in Nigeria
Air Con is always On
The Car is an Automatic, imported from Germany
Enging temp never go above 95, 85 Norrmal
The car starts everytime first try (no gas pedal needed)
It idles at 750 to 850 almost smooth
We have NO quality gasoline

Last month someone (local dirt floor mech) adjusted the fuel mixture with a long allen key thru the airfilter. He used the engine sound to fine tune his adjustment. We have no meters here!

Thanks again!!
Capt. Joe McGlynn
Port Harcourt, Nigeria
__________________
Beautiful Car!
Wish It Ran Beautiful!
Help Please!
Reply With Quote
  #2  
Old 08-09-2003, 12:33 PM
brookspw's Avatar
Registered User
 
Join Date: Dec 2001
Location: Nashville, TN
Posts: 551
O2 sensor?
__________________
1994 C280, dark green metallic
105k miles

1991 190E 2.6, Black
191,500 miles
(sold to another forum member)

2003 Chevy Tahoe LT, Redfire Metallic
105k miles

1989 Mustang GT Cobra Convertible
43k miles
Reply With Quote
  #3  
Old 08-09-2003, 12:36 PM
Registered User
 
Join Date: Nov 2001
Location: Port Harcourt, Nigeria
Posts: 28
idle problems

Wheres the O2 sensor
__________________
Beautiful Car!
Wish It Ran Beautiful!
Help Please!
Reply With Quote
  #4  
Old 08-09-2003, 01:15 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
May I suggest that you Post the Model ?
You will certainly get a better response.
Reply With Quote
  #5  
Old 08-09-2003, 01:23 PM
Registered User
 
Join Date: Nov 2001
Location: Port Harcourt, Nigeria
Posts: 28
Oops!

The car is a 1993 230 E sedan, with a 4 cylinder, automatic.
__________________
Beautiful Car!
Wish It Ran Beautiful!
Help Please!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page