Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-10-2003, 02:21 PM
Pete Geither's Avatar
Half Fast Moderator
 
Join Date: Feb 2002
Location: Western Pa.
Posts: 2,417
Never had this happen

Driving my SL into town today, it started missing as I rounded a curve while accelerating. It missed intermitantly for the next mile or so until I got to our business. Shut it off for a minute or two and when I went to restart it, it would not start. It backfired and smoked out the pipes, but it took me at least 5 minutes of repeated trys to get it running enough to get it into the shop. Let it sit for about an hour, pulled a couple of plugs out of the left bank, which looked fine, put it together, started right up and ran fine since then. Any thoughts??? Will this model,, 1995 SL500, have set any codes that can be retreived?? Will talk to the dealer tomorrow but I know there are people here that can steer me in the right direction. Thanks, Pete
__________________
95 SL500 Smoke Silver, Parchment 64K
07 E350 4matic Station Wagon White 34K
02 E320 4Matic Silver/grey 80K
05 F150 Silver 44K
Reply With Quote
  #2  
Old 08-10-2003, 03:23 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Could have codes, but easily might not.

A recognized misfire will result in fuel signal being cut on your car. They are known for distributer cap misfiring. A number of misfires can be mistaken by the controller and all fuel can be shut-down. Each key stroke is a new event so if the misfire goes away all is better.

Read the codes and visably check the caps and rotors.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 08-10-2003, 04:39 PM
Pete Geither's Avatar
Half Fast Moderator
 
Join Date: Feb 2002
Location: Western Pa.
Posts: 2,417
Thanks Steve. Just had to replace a dist. cap on the 400E for the same problem. Will take a look tonite. Pete
__________________
95 SL500 Smoke Silver, Parchment 64K
07 E350 4matic Station Wagon White 34K
02 E320 4Matic Silver/grey 80K
05 F150 Silver 44K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page