Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-23-2000, 10:07 PM
Posts: n/a
Hope this isn't one of those "intermittemt" electrical gremlins....anyway on my 89 190 E 2.6 about every three weeks or so the number 9 position in the fusebox which runs the rear mounted brake light, water temp and oil pressure guages just stops working...BUT when I check the actual fuse itself the fuse is not blown! Just to be sure I've replaced the fuse with a new one and all is well for about 3 weeks and then......zap! Happened tonight as I was driving home from the U-571 movie (referring to the German sub one of the characters has a great line.....they (Germans) sure know how to build 'em..". Anyone have any ideas on this? I've even cleaned the contacts with tuner cleaner and an eraser on the end of a pencil. Thanks for the input.

Dave Browning
89 190 E 2.6
Reply With Quote
Old 04-23-2000, 10:27 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Check the contacts to be sure they are not bent. I found this on my '87 300E #5 fuse position was loose and gave the same sort of problem. If loose, gently bend downward so it will grip the fuse tighter. Don't over do it. Just a little bend.

Jeff L
1987 300e
1989 300e
1987 BMW 325
Reply With Quote
Old 04-24-2000, 08:46 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I have had to clean the contacts with a wire brush on occasion. This works well. Then you can retention them as the above post states.

Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
Reply With Quote
Old 04-24-2000, 11:21 PM
CMuc's Avatar
Join Date: Jul 1999
Location: Port Coquitlam BC, Can
Posts: 92
Nice Beatle reference

Chris Muc
Auto Tech
'87 300E 330,000 km

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190 fuse box help needed 190edude Tech Help 7 03-18-2004 05:16 PM
Fuse just for power windows in a 190? brookspw Tech Help 2 06-14-2003 12:24 PM
190 16V Fuse number 10 blowing UKEvo Tech Help 4 04-24-2003 02:09 AM
location of fuse for blower mtr on 190 2.3 88 msz1113 Tech Help 1 08-16-2002 12:26 AM
300E Blower Motor Fuse JONLYDONLY Tech Help 1 08-18-1999 08:25 PM

All times are GMT -4. The time now is 06:25 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page