Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-11-2003, 05:04 PM
fbins
Guest
 
Posts: n/a
Lifter noise after top-end overhaul on 2.6 w/185k

Just had top-end done with new valves on the #1 cylinder. In addition, all new seals, guides, gaskets etc., But now I have a lifter tick on the #1 cylinder. It wasn't there before the valves were replaced. Mechanic says give it time and it will go away
in all likelihood and it won't hurt to drive it with the tick. Just drive it easy, no more than 2000 rpm, and give it time. I have driven
a little more than 200 miles, and the lifter tick is still there. The mechanic still feels the lifter is not "pumping up". Any suggestions
or similar experiences after a top-end job? I'm using 10w30
motor oil, should I go to a 10w40 or 20w50? Replace the lifter?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page