Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2003, 04:01 PM
Cigar Havana's Avatar
Registered User
 
Join Date: Jan 2003
Location: Toronto Canada
Posts: 379
Unhappy Trunk Light 1989 420 SEL not Working

My trunk light doesn't work and I'm wondering what the experts recommend to get it working? The bulb is good. The switch is good, tested with ohm meter. 3 wires go into the switch/light assembly: a brown, a red with white strip and brown red with white dots. I checked all 3 wires for voltage, no juice, ( volt meter neg. to ground and positive to all of the terminals). The wiring diagram says the red with white strip goes to fuse 15, and should provide the + volts. All other courtesy lights work and the antenna works. Funny thing is, the brown should go to ground, and it doesn't according to the ohm meter.

All 3 wires have one braided sheath, and merge into a large cable at the rear of the trunk and then the cable disappears behind the back seat, and then snakes under the floor. The sheaths look in good shape, no tears.

Where is the grounding point for the brown wire from the trunk light? Is there a junction point for the wire with red with white strip or should it run straight to the fuse box?

Any recommendations on how to trouble shoot this light?

Thanks,
Joe
__________________
1989 420 SEL
Reply With Quote
  #2  
Old 08-21-2003, 06:20 PM
MrCjames's Avatar
California Dreaming
 
Join Date: Jun 2003
Location: SF Bay Area
Posts: 599
Trunk Light

You might find the wires have been compromised at the hinge area from opening and closing the trunk a few dozen times.

Left side hinge area.

Good luck
Reply With Quote
  #3  
Old 08-22-2003, 01:02 AM
Cigar Havana's Avatar
Registered User
 
Join Date: Jan 2003
Location: Toronto Canada
Posts: 379
Wires

You exactly right! At the edge of the hinge, all three wires broken. I had to cut open the nylon braided sheath to find them. Spliced them together, and the trunk light works! Thanks for your suggestion.
__________________
1989 420 SEL
Reply With Quote
  #4  
Old 08-22-2003, 01:40 AM
PaulH's Avatar
Registered User
 
Join Date: Dec 2002
Location: Annapolis,Md
Posts: 431
Wires - cont.

Yep, I had the same problem at the same place.
__________________
Paul 1987 300 SDL; 2000 ML; '69 MGB; '68 VW Fastback
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page