Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-08-2000, 06:45 PM
Wm. Lewallen
Guest
 
Posts: n/a
Problem started when nothing in instrument cluster worked. Checked all fuses and the ice cube relays in the fuse box. All were good. Then I discovered the alternator was not charging. Alternator was okay, but contacts on plug were dirty. Cleaned contacts and now the alternator works fine, but nothing in instrument cluster works. The only thing that does work are the left/right turn signal indicater lights when the hazard warning switch is engaged.Removed instrument cluster;cleaned all contacts, checked bulbs(all good.)Rechecked fuses and relays,All good.Everthing on the car works and is driveable but you have no turn signals, no temp.gauge,no fuel gauge,no oil pressure gauge and the speedometer does not work. What can I do to get all these thing working again? All help will be greatly appreciated.
Wm. Lewallen-- Lexington,Ky.
Reply With Quote
  #2  
Old 05-08-2000, 06:54 PM
Registered User
 
Join Date: Sep 1999
Location: montreal,quebec,canada
Posts: 53
if you remove the instrument cluster you will find a plug which goes into the back; a round connecter with about 16 or so pins.
maybe this came loose????
Reply With Quote
  #3  
Old 05-08-2000, 10:21 PM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,077
this may sound silly, but you never know...What about the dimmer switch?
-Larry

------------------
03/83 300D 184k
07/73 280 160k
Reply With Quote
  #4  
Old 05-08-2000, 11:06 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You have a faulty fuse in the fuse box. I'd replace all of the fuses with the updated ones that are made from copper.
Even when fuses look good, they can be bad. They can burn at the top and bottom contact points where you can't test or see!!!!!! This has kicked my a-- a couple of times!!


------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Woodgrain Instrument Panel Project Strife SL Forum 5 12-30-2004 08:40 PM
107 Instrument Panel Removal 1986 jml214 Tech Help 5 12-12-2004 09:54 PM
Instrument Panel Light is out moo1716 Tech Help 1 11-13-2004 01:07 PM
W201 instrument panel cover removal 190edude Tech Help 3 10-28-2004 05:08 PM
Glow Light off on Instrument Panel dc88168 Diesel Discussion 11 03-12-2002 07:05 PM



All times are GMT -4. The time now is 11:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page