Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-03-2003, 01:48 AM
Registered User
 
Join Date: Sep 2003
Location: Alberta, Canada
Posts: 17
Post Speedometer and Tach Malfunctioning

I've just recently joined this forum and have purchased an 82 300SD. The Speedometer and the Tach/clock don't work. The odometer does function properly. When I pulled out the instrument panel, I noticed the solder around the electrical connection pin that connects to the speedometer wire (green/black) was cracked. I resoldered the connection and the speedometer still does not work. Doing a search on the forum didn't give me many threads on my situation, because my speedometer seems to be an electrical signal and not a mechanical cable.Can anyone point me in the right direction or do have to purchasse another speedometer and if so where can I purchase one. Also can anyone help me in regards to the signal I should be receiving from the tach sending unit coming into the tachometer so I can ensure the sender is working properly or not. Help and Thanks...
__________________
"Life", is the art of drawing, without an eraser.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page