Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-25-2003, 01:13 PM
Registered User
Join Date: Sep 2003
Location: Las Vegas
Posts: 20
88-93 190E 2.6 Expert

I am looking for a couple of experts on the 190E 2.6 who I can contact to help me solve problems related to my Climate Control, Cruise Control, and other problems on my 92 190E 2.6.

Please let me tap your expertise.

Reply With Quote
Old 10-02-2003, 06:16 PM
Registered User
Join Date: Sep 2003
Location: Las Vegas
Posts: 20
Is anyone out there?
Reply With Quote
Old 10-03-2003, 12:17 PM
MrCjames's Avatar
California Dreaming
Join Date: Jun 2003
Location: SF Bay Area
Posts: 599
What problems are you having?
Reply With Quote
Old 10-03-2003, 12:51 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
The forum doesn't makes house calls. You have to spill the beans here for all to read.

95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
Old 10-03-2003, 11:27 PM
The Benzman
Join Date: Jul 2003
Location: NYC - Queens
Posts: 28
Mercedes A/c problems are legendary.

Your cruise control problem could be a Hall effect sensor in back of the speedometer, or an amplifier, or the main unit. But you need to explain your problems more fully before anyone can help you!
Reply With Quote
Old 10-04-2003, 02:22 AM
Registered User
Join Date: Sep 2003
Location: Las Vegas
Posts: 20
Thank you for the reply. I am having a few problems and I was looking for a few owners with experience with the 190 2.6 to establish a direct link...thats all.

Little history.....just bought my 92 190E 2.6 about a month ago with 130,000 miles. All maintenance up to 85,000 was done at the dealership according to the records. It is in pristine condition and was WELL taken care of. I feel I got and excellent deal ($4900).

My problems are that the A/C works great but the climate control center will not change the air flow from dash to the floor or both. Although the A/C works the heater does not.

Cruise control does not work at all. Wont turn on.

Shimmys at 60 mph (have read threads and think I can fix this one by replacing the wheel bearings and the front brakes...along with getting the tires balanced.)

Have read that a lot of the systems are vacume you think the heater and climate control are vacume problems.
Reply With Quote
Old 10-04-2003, 09:24 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
If you have air flow through the center duct then you do not have a vacuum problem. That is you don't have a normal vacuum problem. I have seen systems rigged to just do A/C where the vacuum ran straight of the motor to the heater valve and the center vent.

It takes vacuum to close the heater valve and to open the center vents so it likely is present.

The push button controller activates switchover valves (vacuum gates) which are in one group behind the glove box. There are six or seven switch-over valves and they open and close the vacuum to the various vacuum elements.

To test one should have a vacuum and wiring schematic.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page