Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-01-2000, 08:36 PM
Mahesh
Guest
 
Posts: n/a
The AC has been retrofitted to RJ134A.
Seems to work fine when the cabin is cool (e.g. after overnight) and at higher engine speeds, approximately over 3K rpm. After warm-up at lower speeds and idle it does not work, though the compressor seems to be engaged. Also the aux fan opeartion is intermittent, engages sometimes after the elctro-magnetic fan and sometimes not at all.
Any help is appreciated. Thanks.
Reply With Quote
  #2  
Old 06-01-2000, 11:06 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
More than likely, you are having high pressure problems...You should have them checked at idle. We see the condensor cores cause this more often than not.

------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #3  
Old 06-02-2000, 01:21 PM
Mahesh
Guest
 
Posts: n/a
Benzmac,
Thanks. The problem is now fixed.
For others reference: it was low on refrigerant.

quote:
Originally posted by Benzmac:
More than likely, you are having high pressure problems...You should have them checked at idle. We see the condensor cores cause this more often than not.



Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
500E vs. 190E 16v pentoman Performance Paddock 25 02-26-2007 02:46 PM
190E 8V to 16V conversion Monchit Performance Paddock 1 09-22-2003 06:12 PM
190E front hub bolt patterns: 190E 2.3 vs. 190E 16v haasman Tech Help 5 04-02-2003 05:29 PM
190e 2.3- 16v catalyst daveCT Mercedes Used Parts For Sale & Wanted 5 03-01-2003 01:02 AM
190E 16v Wheels on 190E 8v? JohnEspeed Wheels & Tires 1 03-28-2002 02:01 AM



All times are GMT -4. The time now is 04:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page