Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-02-2003, 01:59 AM
Registered User
Join Date: Oct 2003
Posts: 25
Question 94' E320 blower problem

I am working on a friends MB and the blower motor just quit working. All the A/C stuff works great. I was told by another member how to check it. He said to find the three wire connection by the master cylinder and check for 1-6V on the yellow wire and 12V on the other wire. I found a three wire connector behind the master cylinder and checked for voltage on the white/blue wire and it did not have power on it. This three wire connector has a yellow, white/blue stripe and a black wire. Is this the right connector? There was no voltage on the larger white/blue wire with the ignition on. I am going to recheck these wires again. If I find voltage on this wire then that means I will need to check the blower and regulator next. How do I get to the blower motor. How long will it take to change this blower out and how much do the blower and regulator cost?
thanks for any help JohnT
Reply With Quote
Old 11-03-2003, 09:14 PM
jc300e's Avatar
Registered User
Join Date: May 2000
Location: Location: Norcross, GA
Posts: 119
Just replaced my blower motor in a '92 400E W124. Should be similar. You may have a dust filter on your model. If so, I am not sure how that might change the process. Here's what I did:

Note: Work in an area where you can spread your parts out in the order you remove them. It's not hard, just a lot of little plastic parts.

1. Remove the rubber hood gaskets that runs along the firewall and under the wiper assembly

2. Remove the rubber trim from the bottom of your windshield. (2 pieces on each side of the wiper assembly) (These "snap" in. Carefully pull the trim and they will come out)

3. Remove the platsic skirts directly below the windshield. (2 pieces on each side of the wiper assembly) (Your will see the screws just below the windshield) (The passenger side may be larger due to plastic material that hangs below to cover electronics.

4. Remove 1/2 circle bracket below the wiper. It holds down the rubber skirt attached to the wiper assembly. (Be careful ! Tiny Tiny screws)

5. Remove Wiper assembly.. 4 nuts... 2 visable on right side of assembly. 3rd is located up under rubber skirt closest to the windshield just to the right of the wiper's pivot point. The 4th is just to left of the pivot point...Again...under the skirt next to windshield. The wiper has a modular plug...disconnect it.

6. Remove plastic vent and drain cover. (not sure what you really call's the piece with the screens in it)...There are several screws. The toughest to get to are the ones closest to the engine firewall. You can see them.. just take your time.

7. You should now see the blower assembly. You need to take the top off. There should be 8 clips. Pop them off and remove the cover. Your Blower Motor should be exposed.

8. You will see a metal band accross the center of the motor. The trick is to apply pressure on the strap nearest the back of the clip (closest to the windshield) with another tool, pop the metal clip off the back of the mount. The motor will now pull right out.

9. There are 2 wires connected to the motor (blue and red). just pull them off the posts. Each one has a specific post design. You can't mix up the new connections.

10. Remove the plastic mount. 3 torx head screws.

11. Your new Motor assembly should come with a new mount.

12. Install new mount, plug in motor, and do all the above in reverse order. :-)

I think I covered it all. Give yourself a couple of 3 hours of uninterupted time. You should have no problems. Good luck
'87 300E
'92 400E
'06 ML350
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page