Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-16-2000, 09:34 PM
Registered User
Join Date: Dec 1999
Location: Spring Hill,KS USA
Posts: 17
My 100k SEL has gradually gotten harder to start when cold. It now takes two attempts before it will stay running. Also, the idle has never been as smooth as it should be.
Problem number two is that when going over potholes I hear a distinct knocking noise coming from the front suspension. This has also gotten worse with time. I raised the car on my lift and checked for loose parts but couldn't find anything obvious.
Don't be afraid to go into detail. I have mechanical experience, just none with MB.

Reply With Quote
Old 06-16-2000, 10:29 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
On the start problem, I would check the EHA. IT is under the air filter housing on the side of the fuel distributor housing. It is the small black box that has two wires attached. If it is at all wet with fuel or has any signs of leakage, replace it soon.

On the front end, we see where the sway bar mount bolts come loose or fall out. These are the ones that are on the front under the radiator.

Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
Reply With Quote
Old 06-16-2000, 11:10 PM
Alain V.'s Avatar
Senior Member
Join Date: Aug 1999
Location: KS.
Posts: 458
Tim, you car is an S-E-L (126 chassis) correct?

I think the info Benzmac gave you is for a 107 chassis SL, about the sway bar brackets by the radiator.

The 126 chassis cars usually have play in the "strut rod bushings" when you hear front end noises. These are mounted on the rod that is connected to the lower control arm. They are mounted in a way that they sort of face forward and catch alot of dirt and other debris in the mount, which chews up the boot and allows the joint to wear. This is also where you make the castor adjustment when doing an alignment.

Reply With Quote
Old 06-16-2000, 11:51 PM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Yes,I have replace alot strut rod bushings that cause front end noise,I also recommend check both front lower control arm ball joints replace ball joints if boots show cracke or loose.You can save some labor charge if you do both job at one time.

MB STARS Master Guild Technician,12 years MB tech
6 years independent shop owner
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W123 Creaking Front End rmmagow Diesel Discussion 27 08-31-2014 11:05 PM
W123 Creaking Front End rmmagow Tech Help 2 08-22-2004 08:30 AM
Front end Sags Steve 300D Diesel Discussion 2 06-26-2004 02:05 AM
95 E320 Making a noise at start up jimmydean Tech Help 6 06-09-2004 11:44 AM
Hydraulic lifter noise or injector noise? jrd Tech Help 6 01-06-2000 05:19 AM

All times are GMT -4. The time now is 05:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page