Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-19-2000, 08:33 PM
Registered User
 
Join Date: Jun 2000
Posts: 35
Symptom: When I drive the car between 30-40 MPH (2,000 RPM) and then come to a stop at a light or whatever idling, OR idle the car stationary at around 2,000 RPM, as soon as I completely let off the accelerator and the engine returns to idle the car shakes very noticeably for about 5 seconds and then gradually smooths out. This started about a month ago and the car ('84 300D) has about 120,000mi.

I've replaced both fuel filters and the symptom hasn't gone away. The shaking happens in all gears (I haven't tried reverse at 30-40!) Could this be that the fuel pump is showing signs of failure? Is there some sort of idle adjustment that could be stuck? What would cause shaking and then the problem smoothing out on its own?

Would appreciate help.
Reply With Quote
  #2  
Old 06-19-2000, 11:02 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The first thing I would do is have a tech replace the idle damper. It is on the outside of the pump and is not hard to replace.

------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #3  
Old 06-21-2000, 12:08 PM
Registered User
 
Join Date: Jun 2000
Posts: 35
Ok, I'll go there first. Thanks for the advice
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle rpm on 1993 300SL valtchov Tech Help 5 11-12-2003 11:10 AM
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 11:25 AM
Rough idle when cold 87 300D engrx2 Diesel Discussion 16 11-09-2002 11:48 AM
380SEC idle problem confusing me-help please Michael Bushnell Tech Help 2 05-20-2000 10:18 PM
Mercedes Press release - 2000 models Webmaster Featured Cars 8 10-06-1999 12:54 PM



All times are GMT -4. The time now is 09:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page