Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-23-2003, 04:00 PM
Crowe's Avatar
Benz Enthusiast
Join Date: Apr 2000
Location: Atlanta, GA
Posts: 366
W124 cluster buzzing & gages not working

Here is the situation. The instrument cluster in my 1987 300D W124 today started buzzing continuously when the switch is on and all the gages other than the speedometer do not work. The lights all seem to work, the speedometer, odometer, and clock are working. The car will crank and run as normally. Checked the fuze and it was OK. Any ideas? Thanks
  • 2001 E320
Reply With Quote
Old 11-24-2003, 10:24 AM
A. Rosich's Avatar
Registered User
Join Date: Nov 1999
Location: San Jose, Costa Rica
Posts: 883
Its your fuse, eventhough it appears O.K., it is not. Same thing happened to my E 320.

The fuse appeared perfect, but changed it for a new and it solved the problem. Just change the fuse for a new one.

By the way, a good rule of thumb is changing ALL fuses on your fuse box every 6 to eight years. Not costly at all, and it will save you a lot of headaches.
A. Rosich
CL 500, 1998
S 500 L, 1998
E 320 T, 1995 [Sadly sold ]
Reply With Quote
Old 11-24-2003, 06:02 PM
Crowe's Avatar
Benz Enthusiast
Join Date: Apr 2000
Location: Atlanta, GA
Posts: 366

A. Rosich you are correct. I did some additional research and followed your advise. It was a bad #5 fuze. Thanks,
  • 2001 E320
Reply With Quote
Old 11-25-2003, 10:20 PM
wielder of thor's hammer
Join Date: Jul 2003
Location: Long Island, NY
Posts: 321
is it possible that mercedes wired the buzzing in so you would know when the fuse was blown? A good idea if true, or maybe just a coincidence...
headrivenoise... listen.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:34 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page