Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-10-2003, 09:30 AM
Registered User
 
Join Date: Nov 2000
Location: Vernon, CT
Posts: 1,846
Angry no rear window heat, help!

Here in NJ, as with most of the "Northeast", we got hit with a fair amount of snow/ice. Well it was then that I discovered that my rear window defroster is not working. The switch lights up on the dash, but the window never clears. I checked all the fuses and they are fine. I used a meter and there isn't any voltage getting to the reat hatch. BTW this is on my '87 TD. The only thing I can think of is the relay, which turns out runs several different things. This "combo" relay also runs the rear wiper motor which does work. It also is supposed to control the flashers, which also work. Is it possible that a portion of the relay is bad?
__________________
1999 MB SL500 (101,000 mi)
1983 Porsche 911SC (149,000 mi)
2004 Volvo V70 2.5T (205,000 mi)
2014 Tesla Model S 85 (75,000 mi)
PCA member
MBCA member
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page