Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-13-2003, 06:07 PM
Posts: n/a
Heat on S500 doesn't produce heat:( Its freezing cold outside


Recently I purchased a blower motor w/ regulator off a 96 s500 sedan.. My car is a 95 s500 sedan.. Installed it with no problems. At first, when I put it on cold air max it was blowing cold air in all the vents and hot air in the passenger side window side.. After some time it stopped doing that and blew cold air in all the vents but started blowing hot air through the vents towards the front window (over dashboard)..

A few weeks later it stopped doing that and instead started turning off the a/c on its own and I coudln't restart it w/o opening hood and unplugging the fuse..putting it back in..

everything is working fine now EXCEPT for the heat. it just doesn't blow warm or hot is only blowing fan air. I'm in a hurry so I can't edit etc.
Reply With Quote
Old 12-14-2003, 07:03 AM
Posts: n/a

Looks like we have too many people asking questions and less people who are able to respond I remember a few months ago it was 10:1 ratio not it seems 20:1 hehe
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page