Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-25-2000, 10:42 AM
Posts: n/a
My 107 with a 117 V8 recently developed an erratic idle. There is a clicking sound under the passenger dash as the car warms up. It also has died twice which has never happened. It seems to go away when up to full temperature.

I recently greased the 20 points on the throttle linkage and wonder if I messed something up. I put a film of grease on the rubber at the bottom of the air cleaner and think that is not right and must remove it. Anyone have ideas about this problem?

'85 500SL (Euro)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'83 380 SL fast idle problem Dorbell Tech Help 3 08-23-2004 09:25 PM
1967 230s idle problem techrondon Vintage Mercedes 17 03-29-2004 10:25 AM
1988 300E jumpy oil pressure gauge at idle asiamood Tech Help 3 01-16-2003 11:17 PM
Clicking under dash left side 1985 300D-T Carl123 Tech Help 0 09-30-2000 11:33 PM
1987 190E Clicking Noise in Dash xander6 Tech Help 1 10-15-1999 09:12 PM

All times are GMT -4. The time now is 10:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page