Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-01-2000, 09:45 PM
Posts: n/a
my euro 79 300d has been having some vacume problems for a little while now but the problems is getting bigger. it started with the doors locks not working, then it would not shut off, then the brakes would feel rock hard sometimes, and go to the floor with little stopping power othr times. latly the brakes have been locking up. i had this problem on a old ford, it was the brake booster, would that cause all of my problems or is it the vacume pump, or both. any help would be great.
thanks a lot
Reply With Quote
Old 08-01-2000, 10:40 PM
Larry Delor's Avatar
What, Me Worry?
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,026
Usually brakes will lock up if there is brake fluid on the pads. I find it hard, but not impossible, to believe that this is the case...but you never know. The hard brake pedal would be caused by not having sufficient vacuum to make the booster function. Fix you vacuum problem...not much worse than needing to stop on a dime and hitting several thousand $$'s instead. This ought to take care of the doorlock problem too. With some luck it is only the large rubber diaphragm that needs replacing. You can do this in an hour (including washing your hands after). When you do the repair look and remember where everything goes.
hope this helps

03/83 300D 184k
07/73 280 160k
-88 other 153k
Reply With Quote
Old 08-02-2000, 05:00 AM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
I think Larry want you to replace the rubber diaphragm in the vacuum pump. You need to repair the vaccum pump as soon as possible if it is the problem. A leaking rubber diaphragm in the vacuum pump can cause other damages (search this forum for details). The later 300D does not use diaphragm type pump. The vacumm pump problem should not cause the brake to lock up (one or more tires do not turn causing the car to skid).

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Move Over Enzo, Guess Who Is Getting Carbon Brakes? MTI Open Discussion 4 09-02-2004 04:59 AM
Humming/high pitched noise, stops when brakes applied RKreutzer Tech Help 0 08-06-2003 06:43 PM
1987 560sl Rear Brakes are locking santora4 Tech Help 3 05-06-2003 09:05 PM
Locking Up Brakes with ABS Randall Grubbs Tech Help 10 07-30-2001 02:03 PM
Brakes locking. ABS sensors? arias Tech Help 2 10-26-2000 12:48 AM

All times are GMT -4. The time now is 06:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page