Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-07-2000, 05:44 PM
Registered User
Join Date: Dec 1999
Location: LA, CA
Posts: 109
Today, i started my car and it had a very rough idle. At ~ lunch, I was on the freeway and the car completely stalled. I pulled over and cranked many times just to get the car started. The car had a very rough idle (let's call the symptom 'chugging' like) and would stall upon acceleration from the stop light. I limped to a garage and had a new fuel filter (OEM Bosch from benz bin) installed. The symptoms did not improve. Any ideas/suggestions? intank fuel pump filter clogged? pump pump going bad? TIA!!

90 300CE. 155K mi.
Reply With Quote
Old 08-07-2000, 06:07 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Since your Benz has no in-tank pump that isn't the problem. However the ignition coil OR other high voltage ignition componet may cause this type of problem. Even the crank sensor can cause this. Time for testing when the problem happens, not while running good. Of course a fuel delivery test will show the ability of the fuel pumps to deliver.
Reply With Quote
Old 08-07-2000, 07:05 PM
Registered User
Join Date: Dec 1999
Location: LA, CA
Posts: 109
MB Doc,
preventive intervention advice well noted. however, the car was running quite well up to today. It stuttered a lil wks back, but prompty went away so i never bothered to bring out the service manual.

So I should be checking coil voltage, CAS, etc? I'll change the distributor + rotor tonight. Maybe I'll just give up and tow it to House of Imports... =(

Reply With Quote
Old 08-07-2000, 07:54 PM
Registered User
Join Date: Aug 2000
Posts: 82

Let me know what you find out, I've had the same thing happen to me on my wife's '92 300E. In fact, I posted a note on the subject with one reply suggesting the fuel gage may need replacement. It only seems to happen to my wife's car intermittently when the fuel level is below 1/4 tank.

If I find anything I'll post it here.

Good luck
Reply With Quote
Old 08-07-2000, 09:43 PM
Registered User
Join Date: Dec 1999
Location: LA, CA
Posts: 109
I wish I can help, but my situation is not fuel-level dependent. My tank was 3/4 full today. It was also 99% full the last few times the stuttering (i'd say it's more than mis-fire) happened. My car is now at Herb's volvo/mercedes in Fullerton (I see you're in Long Beach). Will keep you updated.

Reply With Quote
Old 08-08-2000, 10:00 AM
Posts: n/a
I also had a problem with a 300ce that when you open the throttle all the way fast like if you where trying to pass someone, the car would almost die on the spot. but when you opened the throttle slow it would bogg and stutter. it was the ignition coil. I spent all day when I finally called Benzmac and he told me on the spot what it was. But also check your fuel delivery because my father also had a car (560 sel) that did the same). so I would take a fuel guage and check the fuel pressure as you drive the car. Remember have a person who's done this job before do it for safety.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Euro light differences, 500E vs 300E. JCE Tech Help 16 09-20-2004 06:00 PM
Light Control Relay in 300CE endeavor Tech Help 0 08-26-2003 10:13 AM
PIAA Hype ke6dcj Performance Paddock 0 08-30-2001 06:06 PM
Fog Light installation in ML. blau Tech Help 5 02-12-2001 01:05 PM
380SE Third stop light doen't work..HELP? mikeb Tech Help 1 09-27-1999 09:35 PM

All times are GMT -4. The time now is 06:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page