Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-03-2004, 01:20 AM
cheapshot's Avatar
Registered User
 
Join Date: Mar 2004
Location: Bahamas
Posts: 8
Angry C240 ESP message

Nice forum guys. I have a C240 2001 with Electronic Stability program. I bought the car used with 34k miles on the odometer. I had to change the battery and ever since I get an ESP malfunction and I need to visit workshop. It appears to be random. Tonight I reset the fuses for the system (55,56,57,59,60 and 62). I found a 5amp fuse that was blown (location 62) and replaced. Now the ESP is fine and I can now even disable it with ESP button on the dash which I could not do before. Now the malfunction is ESP not available but it appears to be working. Any ideas?

Reply With Quote
  #2  
Old 03-03-2004, 08:38 AM
LarryBible
Guest
 
Posts: n/a
To begin with, don't ever charge your battery without disconnecting the battery first. Been there, done that. Luckily my car was under warranty and they fixed it all up. This would indicate to me that jumping one of these cars will almost certainly cause problems.

After replacing the battery, there are several things that must be reset varying from the ESP to express function in the windows. Consult your owners manual and it will cover all of it.

I followed the instructions in the manual and reset everything. I don't remember the details, you just have to get the manual and work through it. Being certified Operating System Administrator would probably be helpful.

Hope this helps,
Reply With Quote
  #3  
Old 03-03-2004, 09:21 AM
PHAEDRUS242's Avatar
Registered User
 
Join Date: Feb 2004
Location: Shakedown Street
Posts: 423
i imagine you are all right at this moment. a lot of times when a stop lamp switch starts to show an intermittently implausible signal, you will get that warning which will go away when the ignition is cycled. there is also a DTB for your car about a wiring update for the esp control unit due to corrosion on the connectors. if the light is not on there isn't a problem, but i would mention to your service advisor at your next scheduled maintenance that the esp warning appears intermittently.
Reply With Quote
  #4  
Old 03-03-2004, 09:28 AM
cheapshot's Avatar
Registered User
 
Join Date: Mar 2004
Location: Bahamas
Posts: 8
Unhappy

Here is the message I am getting again:"ESP is not functioning please visit workshop". This is after car was parked all night. There is no ESP warning light in the dash (yellow exclamation) but I cannot even disable it now (push the ESP button on the dash to turn on or off). Car is driving fine, just this annoying msg.
Reply With Quote
  #5  
Old 03-03-2004, 01:17 PM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,650
After dis-connecting the battery you need to re-synch the steering angle sensor. With the engine running, just turn the wheel from lock to lock once or twice and that should do it. The codes will still need to be cleared though.
Reply With Quote
  #6  
Old 03-05-2004, 08:36 AM
cheapshot's Avatar
Registered User
 
Join Date: Mar 2004
Location: Bahamas
Posts: 8
How do you clear the codes? Is there a procedure that I can perform myself without having to go to the dealer?
Reply With Quote
  #7  
Old 03-05-2004, 10:02 AM
PHAEDRUS242's Avatar
Registered User
 
Join Date: Feb 2004
Location: Shakedown Street
Posts: 423
no. you need to go to the dealer.
Reply With Quote
  #8  
Old 03-05-2004, 11:08 AM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Quote:
Originally posted by PHAEDRUS242
no. you need to go to the dealer.
It has always been my understanding, once you rectify a problem, codes ( if not reccuring ) will clear themselves, after a certain amount of key-starts/trips.

__________________
2007 C 230 Sport.

Last edited by manny; 03-05-2004 at 11:18 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page