Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-18-2000, 02:50 PM
Registered User
Join Date: Jul 2000
Location: Toronto, CANADA
Posts: 1,193
I was just poking around underthe hood of my 1986 420SEL and noticed a broken hose coupling. There is a three or four inch long hose (about 3/4 inch diameter) that comes out from the passenger side of the engine block. It is located between the oil filter housing and water pump/ alternator (I'm not sure - looks like that kind of thing) The hose goes to what looks like a thermostat (at least it is about that shape and size) I am not down any fluids, and I have run the engine and looked to see if anything was coming out. Is this some kind of exhaust gas release hose? Can anyone enlighten me? It looks like the metal coupling that attaches this hose to the engine block has rusted in hald and that is why it has come off. Expensive to replace/fix?

Please help.

Jason Priest
1986 420SEL
Reply With Quote
Old 08-18-2000, 11:01 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You may be talking about the air injection pump hose. They blow off all of the time. Probably will be big change if the compressor is broken.

Donnie Drummonds
1991 GMC Syclone
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
w115 Steering coupling Finished NC240D76 Vintage Mercedes 3 11-22-2004 08:31 AM
Broken Radiator Hose Fitting, 1981 300D mfripp Diesel Discussion 19 08-16-2004 05:04 PM
Broken Radiator Hose Fitting, 1981 300D mfripp Diesel Discussion 7 08-03-2004 03:25 PM
WTF - Broken Radiator Hose After Diving Hard on my 94' C280 Julius Reymundo Tech Help 10 05-17-2004 11:08 AM
Broken hose? What is it git0 Tech Help 8 11-10-2003 03:53 PM

All times are GMT -4. The time now is 11:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page