Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-26-2000, 04:31 PM
Angel Dust
Posts: n/a
i have a 99 clk 430...the temp gauge has been normal until two days ago and i have no idea why...the temp has always stayed between 80 and the dash above it with no number...but two days ago while on the freeway i felt i needed a little extra push to pass this i chose to downshift to three...i think i was travelling at about 60mph...but i screwed up and downshifted to 2 and hit the gas...the rpm's jumped to redline...and then i backed off on the accelerator after i had passed him and shifted all the way up to D....not long after that i hit really bad traffic and the temp gauge started to go up...i didn't think much because it was 84F outside and i had the A/C on...but last night i was down at the beach where the temp was i think 68F outside...but the temp keeps staying at or near the dash right about the 80 mark...and it won't go down unless i start driving on the freeway with a lot of open air coming into the other words...even with the ambient temp at 68F...and i'm at a red light...the temp reads at the dash above the 80 mark....please there anything wrong?....busted radiator?...or something else?....
Reply With Quote
Old 08-26-2000, 07:13 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
At or around 80 to 88 C is just fine. You're OK. Most MBZ thermostats don't open until about 88 C.

Jeff Lawrence
1987 300e
1989 300e
2000 Dodge Grand Caravan SE
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Temperature monitoring network in my 300D Russo 85300tD Diesel Discussion 15 06-29-2012 01:43 AM
A/C Temperature Readings braverichard Diesel Discussion 8 05-07-2004 04:29 PM
91 350 Sd Temperature Gauge Not Working MarekW Tech Help 5 05-13-2003 12:18 PM
190e Temperature Switches, please help Machnumber2 Tech Help 2 10-14-2002 02:11 PM
Temperature question cossie Tech Help 3 06-02-2000 06:59 PM

All times are GMT -4. The time now is 11:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page