Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-13-2004, 06:58 PM
Registered User
 
Join Date: Apr 2004
Location: Tucker, GA
Posts: 21
E320 Electrical Problems?

I read somewhere that the E320's have a higher than normal electrical failure problem. Am still considering buying a 98 (71,000 miles) and just today noticed a couple of problems. I turned on the fog lights and the right one didn't light. OK, I figured it's just a blown bulb. This afternoon I turned on the headlights and again got a bulb failure message. This time it was the small light (don't really know what you call them) adjacent to the right large headlight. It came on when I put on the bright lights. Out when I dimmed them. What I am trying to figure out is this evidence of an electrical problem or just coincidence that all this happened in a short period of time.
Really appreciate your help, regards
Guy

__________________
Guy Everhart

1998 E320 Wagon
Reply With Quote
  #2  
Old 04-13-2004, 07:10 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Other than a few blown bulbs and a bad electrical contact on the right rear tail light, my 98 E320 has had no other electrical problems.

The only items (non maintenance) that I had to replace are the mass flow meter and harmonic balancer.

Others have had to replace the right rear window regulator but mine is original.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #3  
Old 04-13-2004, 09:10 PM
Registered User
 
Join Date: Apr 2004
Location: Tucker, GA
Posts: 21
Ray,
Thanks for your reply. Carol Stream huh. Seems like my wife has a credit card that I mail payments to Carol Stream. Cool name.

You said that you had a problem with a bad electrical contact on a rear lamp and I wonder if that is what I have, but on the front lamps. Went out and checked things again and now the lamp lights. I hate those intermittent problems. Tried to duplicate conditions when I first noticed problem, but no luck.
Thanks again,
Guy
__________________
Guy Everhart

1998 E320 Wagon
Reply With Quote
  #4  
Old 04-13-2004, 10:57 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Guy,

FYI - Carol Stream is the daughter's name of the founder (Jay Stream) of Carol Stream.

You mentioned that the small light adjacent to the right large headlight only came on with the bright lights. This might be the high beams which only come on with the bright lights. There is another bulb in the small light fixture which comes on with the parking lights. It is the driving light and is much dimmer than the high beams. I had to replace my driving light and found out that only the Mercedes dealer carried these bulbs. If I recall the bulb was under $5.

I find it easier to measure the voltage at the socket to see if the power is going to the socket. This will help narrow down the cause of the problem.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #5  
Old 04-14-2004, 05:45 AM
Registered User
 
Join Date: Mar 2002
Location: Waikele,Hawaii
Posts: 42
Guy,

Maybe it was just my experience, but my 1998 E320 wagon was the reason I am now driving a BMW......

I have owned almost half a dozen MBs and love the make but, the only car to ever, ever leave me stranded was my 1998 E320. It had about 60,000 miles on it and was a Starmark vehicle purchased used from the dealer at 48,000 miles. Maybe it was just it's time, but in my opinion, being stranded once because my car wouldn't start is one thing. But to have the situation happen three trimes and all three times have the dealer tow and replace something different, I lost all faith in the car. Sensor this, sensor that, infrared ignition key replaced, crankshaft position sensor replaced.......it was endless. It was my one and only bad taste in a Benz.

Otherwise I loved everything about the car. Handling, ride, stereo, performance, functionality, ergonomics, and technology. Regrettably, in the end, it's most favorable attribute was the 100k Starmark warranty - which received copious use. In my book, dependability is key. The only other car to come close in lack of dependability was my 1996 XJ6. Even that however, never left me stranded. After stalling, it started right back up - and it only happened once.

Like I said, I am a diehard MB fan and it pains me to relate my experiences. As a matter of fact, I am planning on purchasing another E320 although it will be the old body (1995). That was the best car MB ever made. I love the make but have been very disappointed with some of the newer models. They just don't seem to be as "tight" as the older cars. I detail cars on the side and have had the pleasure of piloting many different makes and models of cars. While each has its own positive attributes depending on its intended market segment, I always end up comparing the car against one of my old Benzs - they truly are the benchmark.

If you decide to get the S210 or W210 body style, or any other car, I hope you will make it a Benz and I wish you happy motoring......

__________________
300SD ('81), 190E ('89), 420SEL ('86?), Jaguar XJ6 VDP ('96), E320 ('95), Jaguar XJ6 ('97), E320 [S210] 4matic wagon ('98), Nissan Maxima SE ('02), DeVille ('93), BMW 325 ('03), LS430 Ultra ('01), Avalon Limited ('05), S430 ('06), MINI Cooper ('05), Toyota Camry ('07), Hyundai Azera Limited ('07), E350 ('06), LS430 ('05)
Current rides:
Nissan Versa ('08), S430 ('03)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page