Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-2004, 09:59 AM
Registered User
 
Join Date: May 2004
Location: Ashburn, VA
Posts: 1
C280 Bad Miss on Even Slight Acceleration

My 94 C280, under even extremely gentle acceleration, started to miss badly. (Check engine light has been on throughout all this). I would have to pull over, shut off the engine, then restart the engine to get rid of the miss. I replaced the gas cap and the spark plugs, which helped tremendously. The miss is almost non-existant now, but still appears under hard acceleration. And again, the only way to get rid of the miss is to turn off the engine, then restart. The check engine light has been on throughout all this. Can anyone help? Thanks! Doug

Reply With Quote
  #2  
Old 05-05-2004, 10:39 AM
Registered User
 
Join Date: Aug 2003
Location: Oakville, ON
Posts: 81
If the CEL is on I suggest you get the codes read.
Reply With Quote
  #3  
Old 05-05-2004, 01:07 PM
Registered User
 
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Code retrieval will probably verify, that you are setting misfire codes.
May want to have a close look at your sparkplug wires.
You could spray them with a fine watermist, while the engine is idling.
__________________
2007 C 230 Sport.
Reply With Quote
  #4  
Old 05-05-2004, 10:48 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
M104.

Wiring harness
Coils if it has the old blue labels in it
really, really bad air flow meter (long shot)



Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #5  
Old 05-10-2004, 10:43 PM
Registered User
 
Join Date: Apr 2004
Location: Florida. Port Saint Lucie.
Posts: 10
replace all three of your coils and replace the boots and plug wires also. Recently had to do the same to my1995 C280

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page