Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2000, 08:51 AM
Dingo
Guest
 
Posts: n/a
HELP!
While removing the instrument cluster of my 1984 300SD I lost the plug that fits into the center of the back of the cluster (It has 6 wires) and now I don't know which wire goes where.

------------------
Travis the Turbodiesel
Reply With Quote
  #2  
Old 09-11-2000, 09:59 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
There is only one connector back there that will fit. You may need to dig to find it.


------------------
Benzmac:
Donnie Drummonds
300E
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #3  
Old 09-12-2000, 08:28 AM
Dingo
Guest
 
Posts: n/a
I guess that I didn't make myself clear ( I sometimes have a problem with that).

I know where the plug itself is and where it goes. The plug itself is in 2 parts and when I removed it it came off 1 part at a time. Unfortunately, I wasn't fast enough to get the wires to the plug marked before they all fell out.

Can you let me know the order of the wires in the plug itself?

Thanks!

------------------
Travis the Turbodiesel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is the odometer memory stored in the instrument cluster on '01 S-class? atikovi Tech Help 1 11-03-2004 09:11 PM
Custom Instrument Cluster for 1992-1994/6 Benzes? jimbobeleeeeeoo Performance Paddock 11 11-01-2004 11:32 PM
124 instrument cluster wiring question schumi Tech Help 3 08-13-2004 10:43 PM
Question on Instrument Cluster Replacement for a 97 E420 (W210) Garry Lay Tech Help 3 06-16-2004 09:05 AM
300 e instrument cluster removal 300e_SMITH Tech Help 1 02-24-2002 10:42 AM



All times are GMT -4. The time now is 09:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page