Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-16-2000, 03:08 PM
Dave F
Posts: n/a
I have a 83, 300SD with a hard brake pedal when trying to stop in reverse gear. In forward gear, the brake pedal is fine. All the doors lock, the car shuts off properly, and all the climate control is ok.

Any suggestions?

Reply With Quote
Old 09-16-2000, 10:00 PM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Your brake booster is not getting enough vacuum,possible cause......vacuum pump,vacuum leak in system,booster is leaking

MB STARS Master Guild Technician,12 years MB tech
6 years independent shop owner
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 e430 brake pedal travel sdhir Tech Help 4 11-21-2004 10:11 AM
126: Brake Pedal Hard on start 300sd2000 Tech Help 3 05-26-2004 12:48 AM
W123 Brake and Fuel hard line replacement BF_JC230 Tech Help 0 03-01-2004 09:36 PM
380 brake pedal -rpm rising Rainman Tech Help 1 06-17-2003 09:52 AM
Brake pedal BenzOnline Tech Help 12 04-04-2003 01:13 AM

All times are GMT -4. The time now is 08:21 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page