Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-24-2000, 12:36 PM
Registered User
Join Date: Jun 2000
Posts: 36
Now that the weather is cooling down in Minnesota, my 87 300TD is running rough when I first start it up and particularly when idling in neutral. Perhaps a little extra diesel smoke, as well. I always use premium diesel of at least 45 cetane. The car just has 66,000 miles on it and I think the injectors are original.

Also, I had the car to an MB dealer in July because it was dieseling. I thought the shut-off valve needed replacing. They said the vacuum lines needed cleaning out and it did take care of the problem. But now, 2 months later it is doing it again, although not as bad. Before, I usually had to push the stop button to turn it off when it was warm. Now, it just runs on for a few seconds.

Does it sound like I have two unrelated problems, or one that is manifesting in more ways now?

Thanks in advance for any input.


Reply With Quote
Old 09-25-2000, 05:41 PM
Registered User
Join Date: Aug 2000
Location: Canada
Posts: 127
Have you ever cleaned the injectors with (a) and Italian tune-up or (b) with the Lubromoly or Redline injector cleaner?
Reply With Quote
Old 09-25-2000, 05:52 PM
Registered User
Join Date: Jun 2000
Posts: 36
I have never used an additive in my 87. My MB dealer recommends never using additives in a diesel with a trap oxidizer. Over the years, I have used injector cleaners and fuel supplements in my 83 300TD, but it doesn't have a trap oxidizer.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
W115 rough idle nachi11744 Vintage Mercedes 14 12-05-2003 08:10 PM
my low, rough idle, stall, hot /start solution: E320/300 rvenerac Tech Help 3 11-20-2003 09:59 AM
Rough start, rough idle jchip Tech Help 1 10-06-2002 09:12 PM

All times are GMT -4. The time now is 01:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page