Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-17-2000, 11:16 AM
Posts: n/a
I have a 1990300D Mercedes that I am ready to blow up or sink.I had the aircondition fixed and the mechanic hasn't figured out why the car won't shut off.(CHANGE MECHANIC?)
He told me to open hood,press the red button and it will shut off..I am 77 years old,had mercedes cars for 40 years and still love my car,
Any suggestions...(GO TO A MERCEDES MECHANIC)
Reply With Quote
Old 09-17-2000, 11:43 AM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Yes go find a tech knows Mercedes diesel,you have vacuum leak in system.(check all vacuum hose,connectors)

MB STARS Master Guild Technician,12 years MB tech
6 years independent shop owner
Reply With Quote
Old 09-17-2000, 08:44 PM
Mr. BILL's Avatar
Ghoulardi Rules!
Join Date: Aug 2000
Location: Austin, TX
Posts: 576
Here's a possible Mickey Mouse short term solution. Try locking your doors BEFORE you shut off the ignition.

I had the same problem and I this did the trick until I got it fixed. I guess it helps build up vacuum, but it worked for me.

Reply With Quote
Old 09-19-2000, 08:36 PM
Posts: n/a
Most likely you need the vacuum shut-off box replaced.It is right on top of the injection pump.
Reply With Quote
Old 09-20-2000, 10:06 PM
fz500sel's Avatar
Happy now in paradise!
Join Date: Nov 1999
Location: Venice, FL - "sharktooth capital of the world"
Posts: 712
Yep, sounds like your boy messed up the vacuum when he was fixin' your a/c system. It uses the vacuum as well and he probably knocked something loose or forgot to hook something back up when he was done.

84 500SEL EURO 87K
85 300D 267K (and still goin' strong)
Reply With Quote
Old 09-21-2000, 04:18 AM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
There are many reasons for the engine run on after the key is removed especially the later model diesel with all the smog devices - a minor vacuum anywhere can cause it.

Here are some of the areas that I can think of now:
(1) bad vacuum shutoff box.
(2) bad key switch.
(3) loose or open rubber connectors
(4) defective smog devices.
(5) defective vacuum valve.
(6) defective or weak engine vacuum pump.

If it is (1), (2), or (6), it will be easy to tell with proper test tools.

Reply With Quote
Old 09-25-2000, 10:36 PM
Registered User
Join Date: Jul 2000
Location: McLean, Virginia
Posts: 254
The shut-off device is one plausible answer, another is if the vacuum pump diaphragm is leaking engine oil into your vacuum system thence to the vacuum line that reaches your ignition key. Do you have any oil seeping out the key slot? That can be fixed by any contortionist. It happened to me once on my 240D. Also,put those nifty little air filters in your vacuum lines at the strategic locations.
Reply With Quote
Old 09-25-2000, 11:43 PM
Registered User
Join Date: Jun 2000
Posts: 60
As many have noted, this is very likely related to a vacuum problem. I have experienced a similar problem on my 240d and 300d when changing the oil. When pulling the top off the oil filter canister, I would accidently pull the vacuum line loose from the shutoff valve. You mentioned the recent work on the A/C, I'm assuming this problem didn't exist previously. This could be as simple as a line pulled loose in the engine compartment. If you don't find a loose vacuum line, you could have a tech check out the shutoff valve on the injector pump, or check for other vacuum leaks in the system. Hope this helps.

1987 300SDL
1989 300E
1986 300E
1981 300D
1983 240D

[This message has been edited by bigbenzman (edited 09-25-2000).]
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS 79' 280CE- Nice car yorktown5 Mercedes Cars For Sale 1 09-08-2004 12:09 PM
Stuff that makes you wonder. Post your pictures!! Cap'n Carageous Open Discussion 88 11-01-2003 03:15 PM
New car owners embarassed by vintage cars? 300SDog Vintage Mercedes 23 02-11-2003 10:47 PM
Glow plug light comes on occasionally while car running Crowe Diesel Discussion 2 09-14-2002 09:28 PM
Now MY car is running hot! Is there no end... blackmercedes Tech Help 0 07-01-2002 01:40 AM

All times are GMT -4. The time now is 12:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page