Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-26-2000, 11:42 PM
Posts: n/a
I have been having a problem with my intermittent wipers ( all other wiper functions operate as normal)... sometimes it is a very brief delay(1 second), sometimes it completes a "double-wipe", and sometimes the delay is 30 seconds or doesnt work at all. Is there a relay (potentially faulty) that controls the wiper delay? Could that be the problem? I have had the car for a year and this has just started. Thanks in advance for ant tips.


95 E420
Reply With Quote
Old 09-27-2000, 06:11 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Yes there a "combo" relay that controls this function. Part # 201-821-02-47. Under plastic cover behind fuse box.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
A Class problems, problems, problems. Eddie Gilmartin Featured Cars 5 07-21-2005 06:37 PM
95s 320 problems are they common?AC/LOCKING system/head gasket leaks joe cantalino Tech Help 0 05-14-2003 10:00 PM
Winter wiper blade on MB mon-wiper loubapache Tech Help 0 03-28-2002 07:02 PM
Windshield wiper problems Doug Vazquez Diesel Discussion 3 12-12-2001 09:46 PM

All times are GMT -4. The time now is 03:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page