Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-28-2000, 12:05 AM
Registered User
Join Date: Aug 2000
Location: Western NC
Posts: 30
just experienced run-on after I try to shut the car off the other day- first time ever, amazingly. The only thing I know about the problem is that it's a mechanical cable shut-off. After that, I'm blind... Ergo, help please!
Reply With Quote
Old 09-29-2000, 09:56 AM
Registered User
Join Date: Jan 2000
Location: PA
Posts: 5,440
1. The cable bracket is mounted to the INJ pump by 3 rubber dampers. If these fail, cable may not pull far enough to shut off engine.
2. Cable may have come off arm in INJ pump.
3. Cable may may just need adjustment in INJ pump bracket.
Let me know if any of the above fixes the problem.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
220D parts car: anyone need anything? (CHEAP!) cscmc1 Mercedes Used Parts For Sale & Wanted 15 11-08-2008 07:49 PM
Hit and Run 95E320cab Tech Help 20 07-16-2003 08:14 PM
Question about Diesel Run On hippie_elmo Diesel Discussion 4 07-29-2002 12:25 PM
Run Your Mercedes On Alcohol 300EVIL Tech Help 7 02-10-2002 12:11 AM
220D + battery lead inquiry cscmc1 Tech Help 0 12-13-2001 11:43 AM

All times are GMT -4. The time now is 05:32 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page