Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-06-2000, 05:41 PM
Registered User
 
Join Date: May 2000
Posts: 317
Recently I changed the oxygen sensor(late August)on my 86 300E , almost immediately noticed when I decelerate I hear back pressure from the cat. I figure the cat. probably has to be replaced(car has 193k mi. on it and also noticed that the metal is peeling). I don't smell rotten eggs or anything. My question is, once I change the cat. (did I wait to long?) do I now have to again replace the oxygen sensor?

------------------
Richie
1986 300E
tint windows
clear corners
euro headlights
16"chrome lorinsers RS90
soon to be 94/95 taillights
Reply With Quote
  #2  
Old 10-06-2000, 07:51 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,777
you shouldn't have to
engatwork
'95 E320
'97 Honda CRV
Reply With Quote
  #3  
Old 10-06-2000, 11:42 PM
CMuc's Avatar
mucman
 
Join Date: Jul 1999
Location: Port Coquitlam BC, Can
Posts: 92
What do you mean back pressure? Do you mean "back firing" or "popping". If it is doing either of these, you probably have an exhaust leak at the o2.
Reply With Quote
  #4  
Old 10-07-2000, 01:12 PM
Registered User
 
Join Date: May 2000
Posts: 317
quote:
Originally posted by CMuc:
What do you mean back pressure? Do you mean "back firing" or "popping". If it is doing either of these, you probably have an exhaust leak at the o2.


What I'm getting is a popping sound.It definitely is NOT backfiring..

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FAIL Emission Test andrew1413 Tech Help 20 04-05-2004 05:07 PM
Engine light DTC codes? 1994 S600 Coupe 600sleeper Tech Help 3 02-24-2003 06:28 PM
Oxygen Sensor Output - Negative Value??? jgl1 Tech Help 4 09-12-2002 09:37 AM
C220 Oxygen sensor question chandrab Tech Help 0 01-12-2002 05:57 PM
560sl Oxygen Sensor santora4 Tech Help 0 01-07-2002 12:28 PM



All times are GMT -4. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page