Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-06-2000, 06:14 PM
Posts: n/a

I hope someone can assist here. I recently replaced the water pump on my 190E 2.6. I had to remove the tandom pump which is both the power steering pump and the hydraulic pump for the ASD locking diff and rear axle level control.

I noticed that the ASD diff seemed too open afterwards, so I bled that by raising one rear wheel, starting the engine and attaching a hose to the bleeder on the diff. A few spins of the raised wheel and the computer kicked on solenoid in and presto... system bled, and quickly too.. lots os excess fluid beyond what the bleeder could hold.

Next, I decided to bleed the rear axle level control... it appears to have been a bad move. The car has always sat a bit high in the rear since new. The car is a 1993 190E 2.6 with Sportline package and Rear Axle Level control and now has 42K miles. I got plenty of aerated hydraulic fluid out and finally clear fluid. Problem is that the rear end sits noticeably lower now. So, what did I do wrong?? I don't think I could have damaged anything by doing this, but I'd like a second opinion about now.

Thanks, KM
Reply With Quote
Old 10-07-2000, 10:29 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Fill it and then drive it some more. It should come back around. If not, you may have the rear valve out of whack.

Donnie Drummonds
Reply With Quote
Old 10-07-2000, 11:24 PM
Posts: n/a
Thanks. I did just that last night and put about 20 miles on the car. The rear axle has come up quite a bit, but comparing to some very recent photos, it's still has a ways to go. I'll drive it some more tomorrow and see how it goes.

Regards, KM
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear brake questions for 92 190E VettesRule Tech Help 6 12-08-2004 10:33 PM
190E 2.6 Climate Control milltek Tech Help 7 09-15-2003 12:31 PM
rear axle bearing johans Vintage Mercedes 0 08-23-2002 11:49 AM
1990 190E rear control arm strut JDUB Tech Help 0 05-22-2001 12:15 AM
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Performance Paddock 3 04-22-2000 11:11 PM

All times are GMT -4. The time now is 03:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page