Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 03-26-2021, 08:48 PM
Registered User
 
Join Date: May 2010
Posts: 164
The ovp date stamp is may 13, 1998 so its not original.

Reply With Quote
  #17  
Old 03-26-2021, 09:07 PM
Registered User
 
Join Date: Sep 2001
Posts: 1,569
Date code and replacement makes sense. When my '93 idle hunted severely it was the MAF. The brake light switch failed a couple of times and it would go into limp home mode. The regulator failed and that triggered ABS, SRS lights and a dead battery.
__________________
Does a Caddy stretch? No, but a Mercedes bendz.
Reply With Quote
  #18  
Old 03-26-2021, 09:11 PM
Registered User
 
Join Date: May 2010
Posts: 164
I have no check engine light or any other lights on the car?
Reply With Quote
  #19  
Old 03-26-2021, 09:23 PM
Registered User
 
Join Date: Sep 2001
Posts: 1,569
I don't think the '93 has a check engine light except in CA IIRC, it's been a while. The MAF did not trip any lights.

Is the EGR valve closing completely?
__________________
Does a Caddy stretch? No, but a Mercedes bendz.
Reply With Quote
  #20  
Old 03-26-2021, 09:32 PM
Registered User
 
Join Date: Sep 2001
Posts: 1,569
Confirmed in owners manual check engine light in CA only. Cluster lens still read "check engine" though.
__________________
Does a Caddy stretch? No, but a Mercedes bendz.
Reply With Quote
  #21  
Old 03-26-2021, 09:48 PM
Registered User
 
Join Date: May 2010
Posts: 164
I will look at the egr valve tomorrow and post here . Just to give an idea . The car runs exactly like the video on victors webpage ...on the non asr throttle body he is explaining. So i should change the ovp?
Reply With Quote
  #22  
Old 03-26-2021, 10:56 PM
Registered User
 
Join Date: Sep 2001
Posts: 1,569
Victor's webpage?
__________________
Does a Caddy stretch? No, but a Mercedes bendz.
Reply With Quote
  #23  
Old 03-27-2021, 08:00 AM
Registered User
 
Join Date: May 2010
Posts: 164
The guy who rebuilds the throttle body for all the w124 in New york. I think his page is restoreyourmercedes.com. He has videos on youtube as well.
Reply With Quote
  #24  
Old 03-28-2021, 10:13 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 737
Also verify Both fuel pumps are operating, if you dont have an inductive amp meter disconnect 1 ground wire at a time , 1 pump may not be operating
Reply With Quote
  #25  
Old 03-29-2021, 09:43 AM
Registered User
 
Join Date: May 2010
Posts: 164
I replaced one of the fuel hoses lines last summer near the pump at the same time i changed the plugs and wires. Will try to test the pumps. If the OVP was bad would the ABS light come on? I was trying to test the EGR but am having a difficult time trying to remove vacuum hose on it. It's on there real tight and i dont want to have to cut it off.
The car ran fine up until a month after the tune up last summer. Before that it sat for awhile and few years back i replaced the CAT as i was always failing emisions. As mentioned before I replaced the ecu about 4 or 5 years ago and the rebuilt throttle body now. I really dont want to start throwing parts at it anymore.
Reply With Quote
  #26  
Old 03-29-2021, 11:46 AM
Registered User
 
Join Date: Dec 2011
Location: Norwalk, CT
Posts: 210
If you are going to keep the car for any length of time pony up for a newer OVP. Super easy to install and having one in there that is 23 years old is not a good idea on these cars.
Reply With Quote
  #27  
Old 03-29-2021, 08:06 PM
Registered User
 
Join Date: May 2010
Posts: 164
I ordered a new OVP relay and tested the EGR valve with the mityvac. I removed the vacuum tube and tested it and was getting nothing. Pumped it to 10 to 15 and nothing ..would drop right away. I am not getting a code reading for it though? Will wait and see with OVP and see how it goes.
Reply With Quote
  #28  
Old 03-30-2021, 07:14 AM
David Hendy's Avatar
Registered User
 
Join Date: Jun 1999
Location: New Milford, Ct
Posts: 1,061
If the harness is made by "delphi" its a replacement. The earliest dated replacement W124 M104 harnesses I have seen were dated 1997.

If it is a replacement, there will be a 2" square tag on the harness that says "delphi" on it, the early tags were grey the later tags white.

If your harness has the Mercedes part number and date stamped on the harness itself then yours is original and is 99.99% likely to be the problem.
__________________
David Hendy
'97 Renntech E60RS
'97 GMC 2500 Sub' Diesel
'95 E300D
'88 300TE
'88 250TD
'84 L/Rover 109
Reply With Quote
  #29  
Old 03-30-2021, 09:07 AM
Registered User
 
Join Date: May 2010
Posts: 164
The wire harness has the white 2 inch tag with the delphi name on it. So it must be a replacement?
Reply With Quote
  #30  
Old 03-30-2021, 12:19 PM
David Hendy's Avatar
Registered User
 
Join Date: Jun 1999
Location: New Milford, Ct
Posts: 1,061
Check all the vacuum hoses especially the large vacuum hose on the TB itself.

You have to find someone with an egas. I have two non asr egas units here, drive here and try one...

__________________
David Hendy
'97 Renntech E60RS
'97 GMC 2500 Sub' Diesel
'95 E300D
'88 300TE
'88 250TD
'84 L/Rover 109
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page