Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-13-1999, 11:36 AM
egruber
Guest
 
Posts: n/a
I have a 98 CLK320. The FM radio does something odd. From listening to it,it seems to pop in and out of 'stereo' mode, even though the indicator always reads 'stereo' on the display. CD and Tape are fine, just FM is a problem. Of course the Dealer cannot reproduce it and MB is resisting authorizing a replacement. Any suggestions?
  #2  
Old 05-13-1999, 12:08 PM
Bill Wood
Guest
 
Posts: n/a
Usually when an FM radio alternates between stereo and mono reception it means that the receiver is not picking up a strong enough signal to deliver a noise free stereo output.
It will automatically switch to mono operation.
Are you having this same problem with all FM stations? The newer Mercedes with the hidden antennas do not get the reception that the older models with external antennas did. Try tuning in a local FM station that you know has a strong signal. If you still have the problem then I would have the antenna and it's connection to the radio checked and possibly the radio itself.

------------------
'98 E430
MBCA-Peachtree

  #3  
Old 05-13-1999, 02:54 PM
egruber
Guest
 
Posts: n/a
Thanks for the advice, Bill.

The problem seems to happen even with strong local stations. The dealer already checked the antenna connections which are OK...and I haven't had any problems regarding reception of stations. They also pulled the control unit for bench testing...which was OK. I just notice that the stereo effect comes and goes while I'm driving (yet the 'stereo' indicator always stays on...which is odd). I think it's a calibration problem within the tuner. I tried the same stations on the same roads with my Toyota, and they play fine. I asked the dealer to temporarily swap it with another one...just to see if it works differently, but he says he needs additional approval for that...which was three weeks ago.
  #4  
Old 05-13-1999, 04:18 PM
Mr. Big
Guest
 
Posts: n/a
I also have a CLK and have the same problem pulling in strong local FM stations here in the L.A. area. I've concluded that this has nothing to do with the head unit--even my cheap $100.00 stereo in my BMW gets better reception--and has everything to do with the hidden antenna. A Japanese manufacturer had the same problem a few years back when they put a hidden antenna in one of their coupe models.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wierd Radio Problem Phalcon51 Car Audio and Multimedia 2 12-14-2003 11:05 AM
Add EQ to Bose radio? richard u Car Audio and Multimedia 1 03-31-2002 08:57 AM
'93 190 E Radio Problem jgl1 Car Audio and Multimedia 1 08-23-2000 09:34 PM
M/B Radio problem Bing Car Audio and Multimedia 3 03-29-2000 12:05 PM
300CD Radio problem jsly Car Audio and Multimedia 3 10-14-1999 06:36 PM



All times are GMT -4. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page