Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-29-2005, 01:18 AM
Registered User
 
Join Date: May 2002
Location: USA
Posts: 1,115
no dash lights, flaky tach, temp and fuel gauge not working...what gives?

on an 82 300TD (wagon)....no dash lights, flaky tach, temp and fuel gauge not working...what gives?

anyone have a pic of a "jumped" reostat (spelling?)?

Reply With Quote
  #2  
Old 12-29-2005, 10:31 AM
Registered User
 
Join Date: Oct 2005
Location: Southport, NC 28461
Posts: 22
You most likely have a loose electrical plug on the back of the dash. Fashion a stiff wire with a small hook in the end, and use the hook to wiggle the dash cluster out enough to disconnect the wires on the back of it (to entirely remove the dash). The large electrical plug is most likely loose.

Regarding no dash lights, naturally check the two dash bulbs first. They are at the top of the dash cluster. If they are fine, your dimmer is probably bad. The dimmer has only two soldered connections to the circuit board...it is pretty obvious which two they are. If you solder a short insulated wire across the two connections, you will have dash lights at the brightest level, which is about a normal setting for me
__________________
'84 300D ~90k
'82 300SD ~171k
'82 240D ~175k
'96 Ram 2500 with 12V Cummins & 5 speed ~130k
Reply With Quote
  #3  
Old 12-29-2005, 10:38 AM
Diesel Giant's Avatar
Registered User
 
Join Date: Oct 2004
Location: Loganville/Atlanta
Posts: 2,156
I never use the wire hook on the cluster thing anymore. I just take 2 screws out of the lower knee panel and stick my hand up to the back of the cluster and push it out.

Works much better.

Check your ground connections.
__________________
1981 300D 147k
1998 VW Jetta Tdi 320k
2001 Dodge Ram 2500 141k
1979 300D 234k (sold)
1984 300D "Astor" 262k(sold)
Mercedes How-To and Repair Pictorials
I love the smell of diesel smoke in my hair
Reply With Quote
  #4  
Old 12-29-2005, 10:39 AM
Registered User
 
Join Date: Dec 2002
Location: RI shore
Posts: 2,937
I snapped a picture when I did mine a while back, but believe me, you don't need it. I'd recommend doing it though, wish I did it 9 years earlier!
__________________
'82 300SD - 361K mi - "Blue"

"Good judgement comes from experience. Experience comes from bad judgement."

listen, look, .........and duck.
Reply With Quote
  #5  
Old 12-29-2005, 11:55 AM
pmari's Avatar
OM606.962 177hp 330nm
 
Join Date: Oct 2004
Location: L.I. N.Y.
Posts: 1,033
Why jump it when the rebuild is so simple...
http://web.archive.org/web/20040603004113/instrument.articles.mbz.org/dimmer/
__________________
1999 E300DT (131,800) 154,000 Black on Black SOLD

2006 CLK 500 coupe Capri Blue on Grey (zoom,zoom)
47,000mi

04 VW TDI Passat 80,000mi
(Techno)

How to eliminate oil dependency through market-driven approaches.
“We could cut oil use in half by 2025, and by 2040, oil use could be zero,”

The Sound of Diesel Speed
Ode to MB
Reply With Quote
  #6  
Old 12-29-2005, 12:16 PM
ImBroke's Avatar
Diesel way of Life
 
Join Date: Jun 2004
Location: Cleveland, NY
Posts: 2,215
Do your other electrics work, ie windows, sunroof?
Reply With Quote
  #7  
Old 12-29-2005, 01:00 PM
Registered User
 
Join Date: Dec 2002
Location: RI shore
Posts: 2,937
Quote:
Originally Posted by pmari
when the spring is hanging out and everything inside is shredded it's not rebuildable like that.
__________________
'82 300SD - 361K mi - "Blue"

"Good judgement comes from experience. Experience comes from bad judgement."

listen, look, .........and duck.
Reply With Quote
  #8  
Old 12-29-2005, 02:47 PM
Registered User
 
Join Date: May 2002
Location: USA
Posts: 1,115
Quote:
Originally Posted by ImBroke
Do your other electrics work, ie windows, sunroof?
windows and other items work fine...manual sunroof
Reply With Quote
  #9  
Old 12-29-2005, 03:06 PM
Registered User
 
Join Date: Dec 2002
Location: RI shore
Posts: 2,937
Quote:
Originally Posted by neumann
windows and other items work fine...manual sunroof
I still pine for the sunroof on my 99. One little tug and it was right where you wanted it - fast.
__________________
'82 300SD - 361K mi - "Blue"

"Good judgement comes from experience. Experience comes from bad judgement."

listen, look, .........and duck.
Reply With Quote
  #10  
Old 12-29-2005, 03:08 PM
sailor15015's Avatar
Reverse lights! Score!
 
Join Date: Apr 2005
Location: Norman, Oklahoma
Posts: 1,184
Most definately check your main grounds, like the body to the chasis. I bought my brother's '84 a week or two ago and a couple of days later it quit starting. The temp and fuel gauges would go crazy before it quit and I just thought it was a shorted out instrument cluster. I swapped clusters from my wrecked '85 and still no dice. The weird thing is that the gauges would peg and every light in the cluster would come on when the speedo cable touched the back of the cluster. I took a jumper cable, hooked it from my EGR to my negative battery post and it started. I didn't have time to look for my main chasis-engine ground because I was leaving on vacation but when I get back I expect to find it in pretty bad shape. Also my other electrical items worked fine up until and during the period when it wouldn't start.
__________________
Seth

1984 300D 225K
1985 300D Donor body
1985 300D Turbo 165K. Totaled. Donor Engine. It runs!!!
1980 300SD 311K My New Baby.
1979 BMW 633csi 62K+++? Dead odo
Reply With Quote
  #11  
Old 12-29-2005, 07:07 PM
Stevo's Avatar
Registered User
 
Join Date: Apr 2002
Location: NW WA
Posts: 6,292
"check your main grounds"

First take a peak under the car at your main ground strap, about abeam the bellhousing, driver side. 13mm I think

There are two you will see if you take out the instrument cluster, look with the flashlight, you cant miss them.

Lose grounds will do all kinka strange things
__________________


1985 Euro 240D 5 spd 140K
1979 240D 5 spd, 40K on engine rebuild
1994 Dodge/Cummins, 5 spd, 121K
1964 Allice Chalmers D15 tractor
2014 Kubota L3800 tractor
1964 VW bug

"Lifes too short to drive a boring car"
Reply With Quote
  #12  
Old 12-29-2005, 09:05 PM
sailor15015's Avatar
Reverse lights! Score!
 
Join Date: Apr 2005
Location: Norman, Oklahoma
Posts: 1,184
Now that you mention it I do remember it being on the bell housing. I also remember I couldn't get the bolt loose. If I do need to replace the strap will it hurt anything to just loosen and re-tighen just one bolt on the bell housing? It won't mess up any kind of alignment?
__________________
Seth

1984 300D 225K
1985 300D Donor body
1985 300D Turbo 165K. Totaled. Donor Engine. It runs!!!
1980 300SD 311K My New Baby.
1979 BMW 633csi 62K+++? Dead odo
Reply With Quote
  #13  
Old 12-29-2005, 09:18 PM
ImBroke's Avatar
Diesel way of Life
 
Join Date: Jun 2004
Location: Cleveland, NY
Posts: 2,215
Quote:
Originally Posted by neumann
manual sunroof
duh,, man sometimes I just can't read.. Of course you have a manual sunroof.. Nevermind that comment..

I agree, either a loose connection, or messed up ground.
Reply With Quote
  #14  
Old 12-29-2005, 09:19 PM
ImBroke's Avatar
Diesel way of Life
 
Join Date: Jun 2004
Location: Cleveland, NY
Posts: 2,215
I'm not with it tonight.

Here's a pic of what a jumpered rheostat could look like.
Attached Thumbnails
no dash lights, flaky tach, temp and fuel gauge not working...what gives?-mvc-051s.jpg  
Reply With Quote
  #15  
Old 12-29-2005, 09:21 PM
Registered User
 
Join Date: Mar 2005
Location: SoCal
Posts: 660
You could also have a burned out wiring behind those instruments. When you take out the instrument cluster remove the metal covers at the back. The thin copper strips under the white paint would sometimes pop like a blown fuse.

__________________
'85 300D Cal 280,000 miles
'07 C230 37,000 miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page