Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Mercedes-Benz SL Discussion Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-2001, 11:23 PM
Registered User
 
Join Date: Feb 2001
Location: Long Island, NY
Posts: 34
Help,

Iíve got the 60,000 miles blues. Iíve tried a search under all sorts of combos with no luck, so at the risk of being redundant I need to ask for help. (posted a few day's ago in tech forum)

My í90 R129 is due for itís 60,000 service and has been operating faultlessly untill tonight. When I lowered the ragtop (all original) the rear deck was very slow to raise and the roof was equally slow to store. This was with the engine running. When I was done the roof almost didnít close. Once again the deck was slow to rise and the roof barely made it of the hump of the halfway mark.

Itís closed now or at least appears to be, however the light is on the alarm sounds when the car is in drive. The top looks closed from the outside but I canít be sure. If you try to open the roof it only seems to unlock from the rear and nothing more, however you can hear the motor running while the switch is engaged.

Is this easy to fix? Iím fairly mechanical if I can find the time, or is there a fuse I can pull to silence the f__king thing while driving it to the dealership.

Oh ya, one more thing I had the rollbar up the last time I shut the roof so it may be related. I lowered the rollbar using the switch since the roof was having such a hard time. The rollbar is also not operative.

thanks
tony

I'll look in the trunk Saterday for the hydro. res.
__________________
'90 MB 500 SL
Reply With Quote
  #2  
Old 08-01-2001, 05:51 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
Sounds to me like you have a hydraulic problem. Check the oil level and if that is still OK, you might have problems with a leaking hose or hydraulic valve. I had a problem with one of the valves/solenoids as well and brought it to the dealer to have it repaired since I figured that it would take too long for me to find what was wrong (this was about 1,5 year ago and I didn't know a thing about the R129 back then).
The beeping sound and flickering switch means that the top is not closed. You probably have to use the top-emergency-tool to close the top manual (locking the second part of the lock, since the top managed to lock the top partly).

The hydraulic system of the top and roll bar is very complex; the rear part of the car is filled with hydraulic lines, valves, switches, solenoids and such. It is not something I would just start trying to repair...

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #3  
Old 08-08-2001, 11:48 PM
BlueBeauty
Guest
 
Posts: n/a
I also have a 1990 SL. Softtop is very slow to move up/down when it is hot (over 25 C, 80 F) weather. Mechanic states that the motor that runs the hydraulic system for the roof needs replacing. Only $1800 USD!!!
In the meantime, I use the wrench that came in the toolkit to manually latch the roof when the red light doesn't go out. Refer to the owner's manual for instructions for manual roof latching. My problem is with the front latches. Swing sun visors out of the way, remove small plugs in the cross pillar, and insert wrench and turn one or two clicks. If the rear pins aren't latching either, you get at them from the trunk. Hope this helps.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
60,000 mile blues - '90 R129 - ragtop problem - search n/g tony s Tech Help 1 07-24-2001 12:32 AM



All times are GMT -4. The time now is 06:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page